summaryrefslogtreecommitdiff
path: root/m4/man-arg-systemdtmpfilesdir.m4
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2014-09-15 23:53:02 +0100
committerColin Watson <cjwatson@debian.org>2014-09-15 23:53:02 +0100
commitf68ad6acc7881628cab00f7637570e1521cd7348 (patch)
treeeee1d78f363dfa166284d3bb7e308de35d02f156 /m4/man-arg-systemdtmpfilesdir.m4
parentb49261c8dc478ed553d59175d57f550be5b3901e (diff)
Move argument handling out of configure to new MAN_ARG_* macros
* m4/man-arg-automatic-create.m4, m4/man-arg-automatic-update.m4, m4/man-arg-cats.m4, m4/man-arg-config-file.m4, m4/man-arg-db.m4, m4/man-arg-device.m4, m4/man-arg-mandirs.m4, m4/man-arg-override-dir.m4, m4/man-arg-sections.m4, m4/man-arg-setuid.m4, m4/man-arg-systemdtmpfilesdir.m4, m4/man-arg-undoc.m4: New files. * configure.ac: Call new macros rather than inlining argument handling.
Diffstat (limited to 'm4/man-arg-systemdtmpfilesdir.m4')
-rw-r--r--m4/man-arg-systemdtmpfilesdir.m414
1 files changed, 14 insertions, 0 deletions
diff --git a/m4/man-arg-systemdtmpfilesdir.m4 b/m4/man-arg-systemdtmpfilesdir.m4
new file mode 100644
index 00000000..c6e94fa9
--- /dev/null
+++ b/m4/man-arg-systemdtmpfilesdir.m4
@@ -0,0 +1,14 @@
+# man-arg-systemdtmpfilesdir.m4 serial 1
+dnl MAN_ARG_SYSTEMDTMPFILESDIR
+dnl Add an --enable-systemdtmpfilesdir option.
+
+AC_DEFUN([MAN_ARG_SYSTEMDTMPFILESDIR],
+[
+AC_ARG_WITH([systemdtmpfilesdir],
+[AS_HELP_STRING([--with-systemdtmpfilesdir=DIR], [Directory for systemd tmpfiles configuration])],
+ [], [dnl
+ # The default is not prefix-sensitive, since systemd's prefix is not
+ # necessarily the same as man-db's.
+ with_systemdtmpfilesdir=/usr/lib/tmpfiles.d])
+AC_SUBST([systemdtmpfilesdir], [$with_systemdtmpfilesdir])
+])