summaryrefslogtreecommitdiff
path: root/m4
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2008-01-15 00:01:42 +0000
committerColin Watson <cjwatson@debian.org>2008-01-15 00:01:42 +0000
commit5a72198ccaabdd4ab780e6b771e28d6570fde7db (patch)
treeb4b7843288e03ddb7ff2ff890b9592aa6d0b6217 /m4
parent05f663de641aea775951e0563696e6088c1af48e (diff)
* m4/man-compress-lib.m4: New function, MAN_COMPRESS_LIB: like
AC_CHECK_LIB but adds the library to LIBCOMPRESS rather than LIBS. * configure.ac: Use it for -lz. * src/Makefile.am (lexgrog_LDADD, man_LDADD, manconv_LDADD, mandb_LDADD, zsoelim_LDADD): Add $(LIBCOMPRESS).
Diffstat (limited to 'm4')
-rw-r--r--m4/man-compress-lib.m413
1 files changed, 13 insertions, 0 deletions
diff --git a/m4/man-compress-lib.m4 b/m4/man-compress-lib.m4
new file mode 100644
index 00000000..eedaadc0
--- /dev/null
+++ b/m4/man-compress-lib.m4
@@ -0,0 +1,13 @@
+# man-compress-lib.m4 serial 1
+dnl MAN_COMPRESS_LIB(LIBRARY, FUNCTION)
+dnl Look for FUNCTION in LIBRARY. If it is available, define HAVE_LIBLIBRARY
+dnl and add -lLIBRARY to LIBCOMPRESS.
+AC_DEFUN([MAN_COMPRESS_LIB],
+[AC_CHECK_LIB(
+ [$1], [$2],
+ [AC_DEFINE_UNQUOTED(
+ AS_TR_CPP([HAVE_LIB$1]), [1],
+ [Define to 1 if you have the `$1' library (-l$1).])
+ LIBCOMPRESS="-l$1 $LIBCOMPRESS"])
+ AC_SUBST([LIBCOMPRESS])
+]) # MAN_COMPRESS_LIB