summaryrefslogtreecommitdiff
path: root/manual
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2019-05-02 12:23:07 +0100
committerColin Watson <cjwatson@debian.org>2019-05-02 12:23:07 +0100
commit49905b5bd15b5a166ac7766b93e4cf02526007db (patch)
tree7b9c4df5a39a5f2d3d492df31bb0f97ee3a7f609 /manual
parent56c355e8a29fff0adbb6e72c95a37ba8ccac2e12 (diff)
Improve manual build portability slightly
* manual/Makefile.am ($(MANUAL).pp, .pp.dvi, .pp.ps, .pp.tdvi, .tdvi.tps, .pp.cat, .pp.html): Use "mv -f" rather than just "mv", since Automake seems to prefer that for its own rules.
Diffstat (limited to 'manual')
-rw-r--r--manual/Makefile.am14
1 files changed, 7 insertions, 7 deletions
diff --git a/manual/Makefile.am b/manual/Makefile.am
index 23321811..8da18831 100644
--- a/manual/Makefile.am
+++ b/manual/Makefile.am
@@ -60,25 +60,25 @@ version: $(top_srcdir)/configure.ac
echo '.ds V $(roff_version)' > $@
$(MANUAL).pp: $(ME_FILES) version
- $(SOELIM) -I$(srcdir) man_db.me | tbl > $@.new && mv $@.new $@
+ $(SOELIM) -I$(srcdir) man_db.me | tbl > $@.new && mv -f $@.new $@
.pp.dvi:
- $(TROFF) -me -Tdvi $< > $@.new && mv $@.new $@
+ $(TROFF) -me -Tdvi $< > $@.new && mv -f $@.new $@
.pp.ps:
- $(TROFF) -me -Tps $< > $@.new && mv $@.new $@
+ $(TROFF) -me -Tps $< > $@.new && mv -f $@.new $@
.pp.tdvi:
- $(TROFF) -me -Tdvi $< | grodvi -d > $@.new && mv $@.new $@
+ $(TROFF) -me -Tdvi $< | grodvi -d > $@.new && mv -f $@.new $@
.tdvi.tps:
- dvips -f -t a4 $< > $@.new && mv $@.new $@
+ dvips -f -t a4 $< > $@.new && mv -f $@.new $@
.pp.cat:
- LC_ALL=C nroff -me $< > $@.new && mv $@.new $@
+ LC_ALL=C nroff -me $< > $@.new && mv -f $@.new $@
.pp.html:
- $(TROFF) -me -Thtml -P-I$* $< > $@.new && mv $@.new $@
+ $(TROFF) -me -Thtml -P-I$* $< > $@.new && mv -f $@.new $@
# Automake defines these targets already, so we need to use -local.
dvi-local: $(MANUAL).dvi