summaryrefslogtreecommitdiff
path: root/patches
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2022-01-02 03:02:41 +0000
committerColin Watson <cjwatson@debian.org>2022-01-02 03:02:41 +0000
commit2b1e6c60072d2a933abffdad59b52202b286b24a (patch)
treea6773809980e6c797b7d29f043a71cbfafb8b5b9 /patches
parent2ce26131ac9cb7444367c809f674624320e8e8e2 (diff)
Update to Gnulib 20211231
In line with Gnulib, we now require Autoconf 2.64. * bootstrap: Sync to Gnulib 14db2b71b5bd05b94ec6126617fd32cd5f1016cd. * bootstrap.conf (GNULIB_REVISION): Set to 14db2b71b5bd05b94ec6126617fd32cd5f1016cd. (buildreq): Bump required autoconf version to 2.64. * configure.ac (AC_PREREQ): Bump to 2.64. (--enable-gcc-warnings): New option, based on code in coreutils. Use this to enable -fanalyzer only if --enable-gcc-warnings=expensive is used; it's useful but slow. * include/manconfig.h.in (create_tempdir, appendstr): Move NODISCARD to the start of these function declarations, required by draft C2x. * patches/argp-domain.patch: Rebase. * NEWS: Document this.
Diffstat (limited to 'patches')
-rw-r--r--patches/argp-domain.patch42
1 files changed, 21 insertions, 21 deletions
diff --git a/patches/argp-domain.patch b/patches/argp-domain.patch
index 0d4c81c2..3297a328 100644
--- a/patches/argp-domain.patch
+++ b/patches/argp-domain.patch
@@ -1,4 +1,4 @@
-commit 6cd59e232112243bca08c588185ce3d397e89fd3
+commit a304ab22b12f41712dbcd41b6ff001feb062b03f
Author: Colin Watson <cjwatson@debian.org>
Date: Mon May 28 17:41:05 2018 +0100
@@ -46,10 +46,10 @@ Date: Mon May 28 17:41:05 2018 +0100
https://lists.gnu.org/r/bug-gnulib/2008-03/msg00144.html
diff --git a/gl/lib/argp-help.c b/gl/lib/argp-help.c
-index de98f2143..09a716e69 100644
+index 80cdb44937..4e600f269d 100644
--- a/gl/lib/argp-help.c
+++ b/gl/lib/argp-help.c
-@@ -48,6 +48,16 @@
+@@ -49,6 +49,16 @@
# include "gettext.h"
#endif
@@ -66,16 +66,16 @@ index de98f2143..09a716e69 100644
#include "argp.h"
#include "argp-fmtstream.h"
#include "argp-namefrob.h"
-@@ -144,7 +154,7 @@ validate_uparams (const struct argp_state *state, struct uparams *upptr)
- if (*(int *)((char *)upptr + up->uparams_offs) >= upptr->rmargin)
+@@ -148,7 +158,7 @@ validate_uparams (const struct argp_state *state, struct uparams *upptr)
{
__argp_failure (state, 0, 0,
-- dgettext (state->root_argp->argp_domain,
-+ dgettext (ARGP_TEXT_DOMAIN,
+ dgettext (state == NULL ? NULL
+- : state->root_argp->argp_domain,
++ : ARGP_TEXT_DOMAIN,
"\
ARGP_HELP_FMT: %s value is less than or equal to %s"),
"rmargin", up->name);
-@@ -220,7 +230,7 @@ fill_in_uparams (const struct argp_state *state)
+@@ -224,7 +234,7 @@ fill_in_uparams (const struct argp_state *state)
if (unspec && !un->is_bool)
__argp_failure (state, 0, 0,
dgettext (state == NULL ? NULL
@@ -84,7 +84,7 @@ index de98f2143..09a716e69 100644
"\
%.*s: ARGP_HELP_FMT parameter requires a value"),
(int) var_len, var);
-@@ -231,7 +241,7 @@ fill_in_uparams (const struct argp_state *state)
+@@ -235,7 +245,7 @@ fill_in_uparams (const struct argp_state *state)
if (un == uparam_names + nuparam_names)
__argp_failure (state, 0, 0,
dgettext (state == NULL ? NULL
@@ -93,7 +93,7 @@ index de98f2143..09a716e69 100644
%.*s: Unknown ARGP_HELP_FMT parameter"),
(int) var_len, var);
-@@ -243,7 +253,7 @@ fill_in_uparams (const struct argp_state *state)
+@@ -247,7 +257,7 @@ fill_in_uparams (const struct argp_state *state)
{
__argp_failure (state, 0, 0,
dgettext (state == NULL ? NULL
@@ -102,7 +102,7 @@ index de98f2143..09a716e69 100644
"Garbage in ARGP_HELP_FMT: %s"), var);
break;
}
-@@ -1120,7 +1130,7 @@ hol_entry_help (struct hol_entry *entry, const struct argp_state *state,
+@@ -1256,7 +1266,7 @@ hol_entry_help (struct hol_entry *entry, const struct argp_state *state,
__argp_fmtstream_putc (stream, *so);
if (!have_long_opt || uparams.dup_args)
arg (real, " %s", "[%s]",
@@ -111,7 +111,7 @@ index de98f2143..09a716e69 100644
stream);
else if (real->arg)
hhstate->suppressed_dup_arg = 1;
-@@ -1142,7 +1152,7 @@ hol_entry_help (struct hol_entry *entry, const struct argp_state *state,
+@@ -1278,7 +1288,7 @@ hol_entry_help (struct hol_entry *entry, const struct argp_state *state,
should be pretty rare anyway... */
__argp_fmtstream_puts (stream,
dgettext (state == NULL ? NULL
@@ -120,7 +120,7 @@ index de98f2143..09a716e69 100644
opt->name));
}
}
-@@ -1156,7 +1166,7 @@ hol_entry_help (struct hol_entry *entry, const struct argp_state *state,
+@@ -1292,7 +1302,7 @@ hol_entry_help (struct hol_entry *entry, const struct argp_state *state,
comma (uparams.long_opt_col, &pest);
__argp_fmtstream_printf (stream, "--%s", opt->name);
arg (real, "=%s", "[=%s]",
@@ -129,7 +129,7 @@ index de98f2143..09a716e69 100644
}
}
-@@ -1176,7 +1186,7 @@ hol_entry_help (struct hol_entry *entry, const struct argp_state *state,
+@@ -1312,7 +1322,7 @@ hol_entry_help (struct hol_entry *entry, const struct argp_state *state,
else
{
const char *tstr = real->doc ? dgettext (state == NULL ? NULL
@@ -138,7 +138,7 @@ index de98f2143..09a716e69 100644
real->doc) : 0;
const char *fstr = filter_doc (tstr, real->key, entry->argp, state);
if (fstr && *fstr)
-@@ -1225,7 +1235,7 @@ hol_help (struct hol *hol, const struct argp_state *state,
+@@ -1361,7 +1371,7 @@ hol_help (struct hol *hol, const struct argp_state *state,
if (hhstate.suppressed_dup_arg && uparams.dup_args_note)
{
const char *tstr = dgettext (state == NULL ? NULL
@@ -147,7 +147,7 @@ index de98f2143..09a716e69 100644
Mandatory or optional arguments to long options are also mandatory or \
optional for any corresponding short options.");
const char *fstr = filter_doc (tstr, ARGP_KEY_HELP_DUP_ARGS_NOTE,
-@@ -1612,11 +1622,11 @@ _help (const struct argp *argp, const struct argp_state *state, FILE *stream,
+@@ -1727,11 +1737,11 @@ _help (const struct argp *argp, const struct argp_state *state, FILE *stream,
if (first_pattern)
__argp_fmtstream_printf (fs, "%s %s",
@@ -161,7 +161,7 @@ index de98f2143..09a716e69 100644
name);
/* We set the lmargin as well as the wmargin, because hol_usage
-@@ -1627,7 +1637,7 @@ _help (const struct argp *argp, const struct argp_state *state, FILE *stream,
+@@ -1742,7 +1752,7 @@ _help (const struct argp *argp, const struct argp_state *state, FILE *stream,
/* Just show where the options go. */
{
if (hol->num_entries > 0)
@@ -170,7 +170,7 @@ index de98f2143..09a716e69 100644
" [OPTION...]"));
}
else
-@@ -1655,7 +1665,7 @@ _help (const struct argp *argp, const struct argp_state *state, FILE *stream,
+@@ -1770,7 +1780,7 @@ _help (const struct argp *argp, const struct argp_state *state, FILE *stream,
if (flags & ARGP_HELP_SEE)
{
@@ -179,7 +179,7 @@ index de98f2143..09a716e69 100644
Try '%s --help' or '%s --usage' for more information.\n"),
name, name);
anything = 1;
-@@ -1682,7 +1692,7 @@ Try '%s --help' or '%s --usage' for more information.\n"),
+@@ -1797,7 +1807,7 @@ Try '%s --help' or '%s --usage' for more information.\n"),
{
if (anything)
__argp_fmtstream_putc (fs, '\n');
@@ -188,7 +188,7 @@ index de98f2143..09a716e69 100644
"Report bugs to %s.\n"),
argp_program_bug_address);
anything = 1;
-@@ -1883,8 +1893,7 @@ __argp_failure (const struct argp_state *state, int status, int errnum,
+@@ -1998,8 +2008,7 @@ __argp_failure (const struct argp_state *state, int status, int errnum,
# endif
# endif
if (! s && ! (s = strerror (errnum)))
@@ -199,7 +199,7 @@ index de98f2143..09a716e69 100644
#endif
}
diff --git a/gl/lib/argp-parse.c b/gl/lib/argp-parse.c
-index ae55e9e19..3f8b0ba69 100644
+index 053495ec03..23f54f3aa7 100644
--- a/gl/lib/argp-parse.c
+++ b/gl/lib/argp-parse.c
@@ -40,6 +40,16 @@