summaryrefslogtreecommitdiff
path: root/src/descriptions.h
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2022-09-23 22:56:44 +0100
committerColin Watson <cjwatson@debian.org>2022-09-23 22:56:45 +0100
commitfdf2f3db554c777cf40d7e26b947f33a67b67b46 (patch)
treebb28c26a7c7aa03233fd1637bdb0f0b737490562 /src/descriptions.h
parentc75db17332c9154c0b1648e022e0f2d6f4ca6e7a (diff)
Move manual page file name utilities to lib/
* src/filenames.c: Move to ... * lib/filenames.c: ... here. * src/filenames.h: Move to ... * lib/filenames.h: ... here. Update positioning of all includes. * lib/Makefile.am (libman_la_SOURCES): Add `filenames.c` and `filenames.h`. * src/Makefile.am (man_recode_LDADD): Link with `$(LIBMAN)` instead of `$(LIBMANDB)`. (lexgrog_SOURCES, man_SOURCES, mandb_SOURCES): Remove `filenames.c` and `filenames.h`. * po/POTFILES.in: Rename `src/filenames.c` to `lib/filenames.c`. * lib/filenames.c (gripe_bogus_manpage): Remove `quiet < 2` condition. (filename_info): Add `warn_if_bogus` parameter; only call `gripe_bogus_manpage` if it is set. Update all callers. * lib/filename.h (filename_info): Update prototype. * libdb/db_storage.h (struct mandata): Move to ... * lib/filenames.h (struct mandata): ... here. Add includes where necessary.
Diffstat (limited to 'src/descriptions.h')
-rw-r--r--src/descriptions.h4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/descriptions.h b/src/descriptions.h
index 38ae412a..0712b643 100644
--- a/src/descriptions.h
+++ b/src/descriptions.h
@@ -22,7 +22,9 @@
#include "gl_list.h"
-#include "db_storage.h"
+#include "filenames.h"
+
+#include "mydbm.h"
struct page_description {
char *name;