summaryrefslogtreecommitdiff
path: root/src/manp.h
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2009-03-14 13:54:29 +0000
committerColin Watson <cjwatson@debian.org>2009-03-14 13:54:29 +0000
commit182af48eb2e1e73348b718def098a84683492d3f (patch)
tree2afcdd4fb3f5329735b31a819d917a132da7212e /src/manp.h
parented6c1b1f5b4fafe11f5ac4a94b3cc874311d6696 (diff)
* man/Makefile.am (EXTRA_DIST): Distribute check-man.
* src/manp.c (read_config_file): Add argument to control whether the main configuration file is optional. Use a static variable to track whether we'\''ve been called already. (get_manpath): read_config_file will keep track of whether it'\''s been called already for itself. Pass new argument. * src/manp.h (read_config_file): Update prototype. * src/man.c (main): Treat the main configuration file as optional if -l was given, since in that case we can get by well enough without it. This makes it easier to run '\''make check'\'' without first running '\''make install'\''.
Diffstat (limited to 'src/manp.h')
-rw-r--r--src/manp.h2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/manp.h b/src/manp.h
index 1168c9f9..1d5b5d0d 100644
--- a/src/manp.h
+++ b/src/manp.h
@@ -40,7 +40,7 @@ extern void free_pathlist (char **mp);
extern char *get_mandb_manpath (void);
extern char *get_catpath (const char *name, int cattype);
extern int is_global_mandir (const char *dir);
-extern void read_config_file (void);
+extern void read_config_file (int optional);
extern const char *get_def (const char *thing, const char *def);
extern const char *get_def_user (const char *thing, const char *def);
extern const char **get_sections (void);