summaryrefslogtreecommitdiff
path: root/tools
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2014-09-09 01:25:48 +0100
committerColin Watson <cjwatson@debian.org>2014-09-09 01:25:48 +0100
commit3605cd9a3b1235955d016bd300a38ac4718dc7d3 (patch)
treea188b75e784b3c4e3006564e05881111a23559e3 /tools
parent58ba1a2a8322c59095bf46e6aec117767d082caf (diff)
Switch away from obsolescent utime function
POSIX.1-2008 marks utime as obsolescent. Switch to variants of the futimens/utimensat family instead, via Gnulib. Use higher-precision times for cat pages. * gnulib: Import stat-time and utimens modules. * src/man.c (man_modtime): Change type to struct timespec. (commit_tmp_cat): Use utimens rather than utime. (display): Store a higher-precision modification timestamp for man_file.
Diffstat (limited to 'tools')
-rw-r--r--tools/Makefile.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/tools/Makefile.in b/tools/Makefile.in
index ce0ea950..3917d8ed 100644
--- a/tools/Makefile.in
+++ b/tools/Makefile.in
@@ -96,6 +96,7 @@ am__aclocal_m4_deps = $(top_srcdir)/m4/man-bdb.m4 \
$(top_srcdir)/gnulib/m4/btowc.m4 \
$(top_srcdir)/gnulib/m4/canonicalize.m4 \
$(top_srcdir)/gnulib/m4/chdir-long.m4 \
+ $(top_srcdir)/gnulib/m4/clock_time.m4 \
$(top_srcdir)/gnulib/m4/close.m4 \
$(top_srcdir)/gnulib/m4/closedir.m4 \
$(top_srcdir)/gnulib/m4/codeset.m4 \
@@ -134,6 +135,7 @@ am__aclocal_m4_deps = $(top_srcdir)/m4/man-bdb.m4 \
$(top_srcdir)/gnulib/m4/getlogin_r.m4 \
$(top_srcdir)/gnulib/m4/getopt.m4 \
$(top_srcdir)/gnulib/m4/gettext.m4 \
+ $(top_srcdir)/gnulib/m4/gettime.m4 \
$(top_srcdir)/gnulib/m4/gettimeofday.m4 \
$(top_srcdir)/gnulib/m4/glibc21.m4 \
$(top_srcdir)/gnulib/m4/glob.m4 \
@@ -214,6 +216,7 @@ am__aclocal_m4_deps = $(top_srcdir)/m4/man-bdb.m4 \
$(top_srcdir)/gnulib/m4/size_max.m4 \
$(top_srcdir)/gnulib/m4/sleep.m4 \
$(top_srcdir)/gnulib/m4/ssize_t.m4 \
+ $(top_srcdir)/gnulib/m4/stat-time.m4 \
$(top_srcdir)/gnulib/m4/stat.m4 \
$(top_srcdir)/gnulib/m4/stdalign.m4 \
$(top_srcdir)/gnulib/m4/stdarg.m4 \
@@ -241,8 +244,12 @@ am__aclocal_m4_deps = $(top_srcdir)/m4/man-bdb.m4 \
$(top_srcdir)/gnulib/m4/tempname.m4 \
$(top_srcdir)/gnulib/m4/threadlib.m4 \
$(top_srcdir)/gnulib/m4/time_h.m4 \
+ $(top_srcdir)/gnulib/m4/timespec.m4 \
$(top_srcdir)/gnulib/m4/unistd-safer.m4 \
$(top_srcdir)/gnulib/m4/unistd_h.m4 \
+ $(top_srcdir)/gnulib/m4/utimbuf.m4 \
+ $(top_srcdir)/gnulib/m4/utimens.m4 \
+ $(top_srcdir)/gnulib/m4/utimes.m4 \
$(top_srcdir)/gnulib/m4/vasnprintf.m4 \
$(top_srcdir)/gnulib/m4/vasprintf.m4 \
$(top_srcdir)/gnulib/m4/vsnprintf.m4 \
@@ -849,6 +856,7 @@ LIBPTH_PREFIX = @LIBPTH_PREFIX@
LIBS = @LIBS@
LIBTHREAD = @LIBTHREAD@
LIBTOOL = @LIBTOOL@
+LIB_CLOCK_GETTIME = @LIB_CLOCK_GETTIME@
LINGUAS = @LINGUAS@
LIPO = @LIPO@
LN_S = @LN_S@