summaryrefslogtreecommitdiff
path: root/tools
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2014-09-11 12:35:52 +0100
committerColin Watson <cjwatson@debian.org>2014-09-11 12:53:50 +0100
commitd84ec58866c50d064938b85e5379c324cf25654a (patch)
tree37630437362362b233398aadd7688b47309874d6 /tools
parent8cabdfbf42bdb94bdc500ae4463d0e498349946f (diff)
Speed up the test suite if we have high-precision file timestamps
* configure.ac: Substitute STAT_HAS_NSEC as "yes" or "no" depending on whether high-precision file timestamps are available. * src/tests/Makefile.am (TESTS_ENVIRONMENT): Export STAT_HAS_NSEC to tests. * src/tests/testlib.sh (next_second): Do nothing if STAT_HAS_NSEC is "yes".
Diffstat (limited to 'tools')
-rw-r--r--tools/Makefile.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/tools/Makefile.in b/tools/Makefile.in
index 264b0ec9..12b530cb 100644
--- a/tools/Makefile.in
+++ b/tools/Makefile.in
@@ -1098,6 +1098,7 @@ SET_MAKE = @SET_MAKE@
SHELL = @SHELL@
SIG_ATOMIC_T_SUFFIX = @SIG_ATOMIC_T_SUFFIX@
SIZE_T_SUFFIX = @SIZE_T_SUFFIX@
+STAT_HAS_NSEC = @STAT_HAS_NSEC@
STDALIGN_H = @STDALIGN_H@
STDARG_H = @STDARG_H@
STDBOOL_H = @STDBOOL_H@