summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--NEWS.md2
-rw-r--r--configure.ac1
-rw-r--r--m4/man-arg-snapdir.m417
-rw-r--r--src/man_db.conf.in2
4 files changed, 21 insertions, 1 deletions
diff --git a/NEWS.md b/NEWS.md
index efd9318e..5374df72 100644
--- a/NEWS.md
+++ b/NEWS.md
@@ -20,6 +20,8 @@ Improvements:
* Make the man-db manual build reproducible.
* Add some hardening options to the `systemd` service.
+ * `configure` now has a `--with-snapdir` option, for use on systems where
+ `snapd` is configured to use a directory other than `/snap`.
man-db 2.10.1 (10 February 2022)
================================
diff --git a/configure.ac b/configure.ac
index 366131cb..93bd1520 100644
--- a/configure.ac
+++ b/configure.ac
@@ -43,6 +43,7 @@ MAN_ARG_SYSTEMDTMPFILESDIR
MAN_ARG_SYSTEMDSYSTEMUNITDIR
MAN_ARG_MANDIRS
MAN_ARG_MANUAL
+MAN_ARG_SNAPDIR
# Check $PATH for the following programs and append suitable options.
AC_PROG_CC
diff --git a/m4/man-arg-snapdir.m4 b/m4/man-arg-snapdir.m4
new file mode 100644
index 00000000..3cf666aa
--- /dev/null
+++ b/m4/man-arg-snapdir.m4
@@ -0,0 +1,17 @@
+# man-arg-snapdir.m4 serial 1
+dnl MAN_ARG_SNAPDIR
+dnl Add a --with-snapdir option.
+
+AC_DEFUN([MAN_ARG_SNAPDIR],
+[
+AC_ARG_WITH([snapdir],
+[AS_HELP_STRING([--with-snapdir=DIR], [use snap system directory DIR [DIR=/snap]])],
+ [if test "$withval" = "yes" || test "$withval" = "no"
+ then
+ AC_MSG_ERROR([--with-snapdir requires an argument])
+ else
+ snapdir="$withval"
+ fi],
+ [: ${snapdir=/snap}])
+AC_SUBST([snapdir])
+])
diff --git a/src/man_db.conf.in b/src/man_db.conf.in
index 2942000f..042fc599 100644
--- a/src/man_db.conf.in
+++ b/src/man_db.conf.in
@@ -69,7 +69,7 @@ MANDB_MAP /usr/local/man /var/cache/man/oldlocal
MANDB_MAP /usr/local/share/man /var/cache/man/local
MANDB_MAP /usr/X11R6/man /var/cache/man/X11R6
MANDB_MAP /opt/man /var/cache/man/opt
-MANDB_MAP /snap/man /var/cache/man/snap
+MANDB_MAP @snapdir@/man /var/cache/man/snap
#
#---------------------------------------------------------
# Program definitions. These are commented out by default as the value