summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorCarlos Henrique Lima Melara <charlesmelara@outlook.com>2020-06-27 15:53:53 -0300
committerAndrej Shadura <andrewsh@debian.org>2020-07-06 13:18:51 +0200
commit41e38fc6d260a959e9919acc8df2035e50ed0055 (patch)
tree9f43ebb9c0679dc5ef0f7c277e491dd3640c7958 /debian/rules
parent49a6a04bb85ce9b023773113a2ee9381c43b0a87 (diff)
debian/rules: migrate to the new (reduced) format
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules51
1 files changed, 5 insertions, 46 deletions
diff --git a/debian/rules b/debian/rules
index ae593ac..71e38fa 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,51 +1,10 @@
#!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
-
-# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
-build: build-stamp
-build-stamp:
- #Nothing to do
- dh_testdir
- touch build-stamp
-
-build-arch: build
-build-indep: build
-
-binary: binary-arch binary-indep
+%:
+ dh $@
-binary-arch: build
- #Nothing to do
-
-binary-indep: build
- dh_testdir
- dh_testroot
- dh_prep
-
- #Install files
- dh_install --exclude=license.txt
- dh_installdocs
- dh_installmenu
- dh_installman
- dh_installchangelogs
- dh_link
- dh_compress
- dh_fixperms
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
-clean:
- dh_testdir
- dh_testroot
+override_dh_clean:
dh_clean
-
-.PHONY: build clean binary-indep binary-arch binary
+ # Removes script created by the makefile
+ rm -f mcu8051ide