summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDimitri John Ledkov <xnox@debian.org>2015-11-08 12:21:52 +0000
committerDimitri John Ledkov <xnox@debian.org>2015-11-08 12:21:52 +0000
commit6878e3ca34c239cc8adbeb3ad7637f5833045b1a (patch)
treeb2a72278f162b3c348a65095bb1c830635e74c3e
parent92726de859f39e6029a8aff8e05fa42bce4cccf9 (diff)
Ignore errors attempting to apply *nice to checkarray, it may be done already. (Closes: #791554)
-rw-r--r--debian/changelog4
-rw-r--r--debian/checkarray4
2 files changed, 6 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 32aa9749..00a62958 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -14,6 +14,10 @@ mdadm (3.3.4-1) unstable; urgency=medium
* Copy AUTO lines from host into initrd, when updating initrd.
(Closes: #785104)
+ [ Martin von Wittich ]
+ * Ignore errors attempting to apply *nice to checkarray, it may be
+ done already. (Closes: #791554)
+
-- Dimitri John Ledkov <xnox@debian.org> Sun, 08 Nov 2015 11:48:03 +0000
mdadm (3.3.2-5) unstable; urgency=medium
diff --git a/debian/checkarray b/debian/checkarray
index 88266c45..1fb97356 100644
--- a/debian/checkarray
+++ b/debian/checkarray
@@ -205,8 +205,8 @@ for array in $arrays; do
resync_pid=$(ps -ef | awk -v dev=$array 'BEGIN { pattern = "^\\[" dev "_resync]$" } $8 ~ pattern { print $2 }')
if [ -n "$resync_pid" ]; then
[ $quiet -lt 1 ] && echo "$PROGNAME: I: selecting $ionice I/O scheduling class and $renice niceness for resync of $array." >&2
- ionice -p "$resync_pid" $ioarg || :
- renice -n $renice -p "$resync_pid" 1>/dev/null || :
+ ionice -p "$resync_pid" $ioarg 2>/dev/null || :
+ renice -n $renice -p "$resync_pid" 1>/dev/null 2>&1 || :
break
fi
sleep 1