summaryrefslogtreecommitdiff
path: root/debian/patches/debian-no-Werror.diff
diff options
context:
space:
mode:
authorMichael Tokarev <mjt@tls.msk.ru>2012-04-12 22:38:14 +0400
committerMichael Tokarev <mjt@tls.msk.ru>2012-04-12 22:38:14 +0400
commit491715b9ff020cb2408eeb5cfd67d86097ddd280 (patch)
tree237bcbb74373a9babc85032a980ffecea652ab87 /debian/patches/debian-no-Werror.diff
parentb36c1880eac4e2c22783ad0e088a5e27cd2d4121 (diff)
switch from topgit to plain 3.0 (quilt)
Diffstat (limited to 'debian/patches/debian-no-Werror.diff')
-rw-r--r--debian/patches/debian-no-Werror.diff26
1 files changed, 26 insertions, 0 deletions
diff --git a/debian/patches/debian-no-Werror.diff b/debian/patches/debian-no-Werror.diff
new file mode 100644
index 00000000..e88db590
--- /dev/null
+++ b/debian/patches/debian-no-Werror.diff
@@ -0,0 +1,26 @@
+From: martin f. krafft <madduck@debian.org>
+Subject: Remove -Werror from compiler flags
+
+-Werror seems like a bad idea on released/packaged code because a toolchain
+update (introducing new warnings) could break the build. We'll let upstream
+use it to beautify the code, but remove it for out builds.
+
+Signed-off-by: martin f. krafft <madduck@debian.org>
+
+---
+ Makefile | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index b8d363f..63d9742 100644
+--- a/Makefile
++++ b/Makefile
+@@ -42,7 +42,7 @@ KLIBC_GCC = gcc -nostdinc -iwithprefix include -I$(KLIBC)/klibc/include -I$(KLIB
+
+ CC = $(CROSS_COMPILE)gcc
+ CXFLAGS = -ggdb
+-CWFLAGS = -Wall -Werror -Wstrict-prototypes -Wextra -Wno-unused-parameter
++CWFLAGS = -Wall -Wstrict-prototypes -Wextra -Wno-unused-parameter
+ ifdef WARN_UNUSED
+ CWFLAGS += -Wp,-D_FORTIFY_SOURCE=2 -O
+ endif