summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorDimitri John Ledkov <xnox@debian.org>2015-11-08 11:58:32 +0000
committerDimitri John Ledkov <xnox@debian.org>2015-11-08 11:58:32 +0000
commit5588e1fa4f0ef3f1e2d0fd663bf48bffbfe684be (patch)
tree673dee33b8f58dfe76156b317962662a6350fa30 /debian/rules
parent4a93a50bf7eb9840797d930346f8f585a3b17e80 (diff)
Fix FTCBFS. Export CROSS_COMPILE=<triplet>- (Closes: #794335)
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules1
1 files changed, 1 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 7b21d228..7a45299a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,6 +6,7 @@
#export DH_VERBOSE=1
+export CROSS_COMPILE=$(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)-
LDFLAGS = $(shell dpkg-buildflags --get LDFLAGS)
CXFLAGS = $(shell dpkg-buildflags --get CFLAGS) \
$(shell dpkg-buildflags --get CPPFLAGS)