summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authormartin f. krafft <madduck@madduck.net>2008-06-24 21:27:01 +0100
committermartin f. krafft <madduck@madduck.net>2008-06-24 21:47:46 +0100
commit36952ccce00b439764eb846b170ffe86e72e0a99 (patch)
treefd819e76d19b47fbec38a66177413f91aefdee99 /debian
parent677b5400b5564373e0030ddda1ff63ccf79f529b (diff)
Moved mdadm-raid init.d script to position S60 (from S50) for runlevels 0 and 6, so that arrays get stopped after cryptdisks-early; thanks to J.M.Roth (closes: #486012).
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog3
-rw-r--r--debian/mdadm.postinst10
-rwxr-xr-xdebian/rules2
3 files changed, 13 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 506d8839..47c49af5 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,6 +4,9 @@ mdadm (2.6.7-1) UNRELEASED; urgency=low
- fixes a segfault when reading /proc/mdstat (closes: #462154).
- fixes a possible bug with v1 bitmap space allocation (closes: #474548).
- supports large files for loop assembly (closes: #463769).
+ * Moved mdadm-raid init.d script to position S60 (from S50) for runlevels
+ 0 and 6, so that arrays get stopped after cryptdisks-early; thanks to
+ J.M.Roth (closes: #486012).
* Fixed a typo in checkarray; thanks to Helmut Grohne (closes: #445540).
* Updated debconf translations:
- Spanish; thanks to Javier Fernández-Sanguino (closes: #477920).
diff --git a/debian/mdadm.postinst b/debian/mdadm.postinst
index 43dd5d66..e15159d7 100644
--- a/debian/mdadm.postinst
+++ b/debian/mdadm.postinst
@@ -173,7 +173,15 @@ esac
if [ "${1:-}" = "configure" ] && [ "${2:-}" = "1.9.0-2.1" ] \
&& test -L /etc/rcS.d/S04mdadm-raid;
then
- update-rc.d -f mdadm-raid remove
+ update-rc.d -f mdadm-raid remove
+fi
+
+if [ "${1:-}" = "configure" ] && dpkg --compare-versions ${2:-2.6.7-1} lt 2.6.7-1; then
+ # stop RAIDs a bit later, see #486012
+ for i in 0 6; do
+ test -L /etc/rc${i}.d/S50mdadm-raid && test ! -L /etc/rc${i}.d/S60mdadm-raid \
+ && mv /etc/rc${i}.d/S50mdadm-raid /etc/rc${i}.d/S60mdadm-raid
+ done
fi
# See #369953
diff --git a/debian/rules b/debian/rules
index f5de6703..1be602ec 100755
--- a/debian/rules
+++ b/debian/rules
@@ -88,7 +88,7 @@ binary-arch: build install
dh_installdebconf
dh_installdocs
dh_installexamples debian/newdisk
- dh_installinit --init-script=mdadm-raid --no-start -- start 25 S . start 50 0 6 .
+ dh_installinit --init-script=mdadm-raid --no-start -- start 25 S . start 60 0 6 .
dh_installinit -- defaults 25
dh_installman
dh_installcron