summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authormadduck <madduck@3cfab66f-1918-0410-86b3-c06b76f9a464>2006-07-22 13:19:41 +0000
committermadduck <madduck@3cfab66f-1918-0410-86b3-c06b76f9a464>2006-07-22 13:19:41 +0000
commit79990c642218a966d9810e2cecc69793ccc4e30a (patch)
tree06d6af264ec895491f64ee1b18012e664ea41cf5 /debian
parent54d00d52f39055ce11492677d5849ea38ade5107 (diff)
* Catching modprobe error in case of absence of the kernel modules, or
a non-modular kernel. Thanks to Holger Levsen.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog4
-rw-r--r--debian/mdadm-raid4
2 files changed, 5 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 609946ec..df89e848 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,10 @@
mdadm (2.5.2-8) unstable; urgency=low
* Re-added rootraiddoc.97.html which was mysteriously lost (closes: #378678).
+ * Catching modprobe error in case of absence of the kernel modules, or
+ a non-modular kernel. Thanks to Holger Levsen.
- -- martin f. krafft <madduck@debian.org> Sat, 22 Jul 2006 14:16:56 +0100
+ -- martin f. krafft <madduck@debian.org> Sat, 22 Jul 2006 14:19:35 +0100
mdadm (2.5.2-7) unstable; urgency=low
diff --git a/debian/mdadm-raid b/debian/mdadm-raid
index 4616c2aa..8515e694 100644
--- a/debian/mdadm-raid
+++ b/debian/mdadm-raid
@@ -69,8 +69,8 @@ case "${1:-}" in
PREFIX="Assembling RAID array"
if is_true $AUTOSTART; then
- if [ ! -f /proc/mdstat ] && [ -x $(command -v modprobe) ] ; then
- modprobe -k md >/dev/null 2>&1
+ if [ ! -f /proc/mdstat ] && [ -x "$(command -v modprobe)" ] ; then
+ modprobe -kq md 2>/dev/null || :
fi
if [ ! -f /proc/mdstat ]; then
log_problem "failed to load RAID subsystem"