summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authormartin f. krafft <madduck@debian.org>2009-10-27 20:08:50 +0100
committermartin f. krafft <madduck@debian.org>2009-10-27 20:08:50 +0100
commit923ab3b75f61dc2e257cf4585beabb680927a22e (patch)
treeab01ccffe252d035346424cab6ffd7c05f61d9f1 /debian
parentf4e3cab93e5ddf39044c78f70b563ae02fbf87da (diff)
fix bugscript and #537734
Signed-off-by: martin f. krafft <madduck@debian.org>
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/bugscript.in6
-rw-r--r--debian/changelog2
2 files changed, 5 insertions, 3 deletions
diff --git a/debian/bugscript.in b/debian/bugscript.in
index 50d19e80..478cc324 100755
--- a/debian/bugscript.in
+++ b/debian/bugscript.in
@@ -38,7 +38,7 @@ if [ $(id -u) != 0 ]; then
yesno "Gather system information as root using sudo? (Y/n) " yep
if [ "$REPLY" = yep ]; then
echo running sudo "$0" "$@"...
- sudo "$0" "$@" && exit 0
+ sudo "$0" "$@" >&3 && exit 0
echo "sudo invocation failed, trying /bin/su..."
fi
fi
@@ -47,8 +47,8 @@ if [ $(id -u) != 0 ]; then
if [ "$REPLY" = yep ]; then
ARGS=
for i in "$@"; do ARGS="${ARGS:+$ARGS }'$1'"; shift; done
- echo "running su root -s '/bin/sh -c $0 $ARGS'..."
- su root -s /bin/sh -c "$0 $ARGS" && exit 0
+ echo "running su root -s '/bin/sh -c $0${ARGS:+ $ARGS}'..."
+ su root -s /bin/sh -c "$0 $ARGS" >&3 && exit 0
unset ARGS
echo "su invocation failed."
fi
diff --git a/debian/changelog b/debian/changelog
index 03c1f2f2..7dc81017 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,6 +5,8 @@ mdadm (3.0.3-1) unstable; urgency=low
(closes: #541884), and add util-linux dependency.
* Copy udev rules into initramfs, which udev stopped doing
(closes: #549535, #549083, #538843, #538143).
+ * Fix the bug script to write debug information to the correct file
+ descriptor (closes: #537734).
* Switch to TopGit and split Debian diff into topic branches; add
README.source.
* Drop the outdated rootraiddoc.97.html document.