summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authormartin f. krafft <madduck@debian.org>2009-03-17 13:59:38 +0100
committermartin f. krafft <madduck@debian.org>2009-04-27 10:02:58 +0200
commitd50915a53bcc1dd036e112d5396cbd226c94a7ad (patch)
tree51352fbcdbf8ef71b29410b112ed755a1fb93eb5 /debian
parent49cb52254ed79d5d6b1550613417520297c0fbf6 (diff)
No longer pass -k to modprobe,
-k has has been deprecated for a long time; thanks to Jan Hudec Debian bug: #519999 Signed-off-by: martin f. krafft <madduck@debian.org>
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog2
-rw-r--r--debian/mdadm-raid2
-rw-r--r--debian/mdadm-startall2
-rw-r--r--debian/mdadm.postinst2
4 files changed, 5 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 4f7d7154..8384fddf 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,8 @@ mdadm (2.6.9-2) unstable; urgency=low
* Fix the check of whether mdadm.conf defines all devices known to the
system; thanks Cristian Ionescu-Idbohrn (closes: #525655).
+ * No longer pass -k to modprobe, which has been deprecated for a long time;
+ thanks to Jan Hudec (closes: #519999).
-- martin f. krafft <madduck@debian.org> Sun, 26 Apr 2009 16:08:28 +0200
diff --git a/debian/mdadm-raid b/debian/mdadm-raid
index dd54df2c..4f242e9f 100644
--- a/debian/mdadm-raid
+++ b/debian/mdadm-raid
@@ -94,7 +94,7 @@ case "${1:-}" in
if is_true $AUTOSTART || is_true ${MDADM_FORCE_AUTOSTART__:-0}; then
if [ ! -f /proc/mdstat ] && [ -x "$(command -v modprobe)" ] ; then
- modprobe -kq md 2>/dev/null || :
+ modprobe -q md 2>/dev/null || :
fi
if [ ! -f /proc/mdstat ]; then
log_problem "failed to load MD subsystem"
diff --git a/debian/mdadm-startall b/debian/mdadm-startall
index 5e54b328..aa947b01 100644
--- a/debian/mdadm-startall
+++ b/debian/mdadm-startall
@@ -11,7 +11,7 @@ set -eu
CONFIG=/etc/mdadm/mdadm.conf
ALTCONFIG=/etc/mdadm.conf
-modprobe -kq md 2>/dev/null || :
+modprobe -q md 2>/dev/null || :
[ ! -f $CONFIG ] && [ -f $ALTCONFIG ] && CONFIG=$ALTCONFIG
diff --git a/debian/mdadm.postinst b/debian/mdadm.postinst
index acd03a66..63a41792 100644
--- a/debian/mdadm.postinst
+++ b/debian/mdadm.postinst
@@ -12,7 +12,7 @@ case "${1:-}" in
configure|reconfigure)
if [ ! -f /proc/mdstat ] && [ -x $(command -v modprobe 2>/dev/null) ]; then
- modprobe -k md >/dev/null 2>&1 || :
+ modprobe md >/dev/null 2>&1 || :
fi
if [ ! -f /proc/mdstat ]; then
echo 'W: mdadm: failed to load MD subsystem.' >&2