summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Shadura <andrewsh@debian.org>2018-10-04 20:57:54 +0200
committerAndrej Shadura <andrewsh@debian.org>2018-10-04 20:57:54 +0200
commitd5d79889787e8d6021531b415560f54d9da181d3 (patch)
treef80b32f23a1aaec8a347896bdc3a9ae779ab47a3
parent77e4922e731003f2b96cb520b746cdbbe7251353 (diff)
Import Upstream version 1.3.4
-rw-r--r--PKG-INFO4
-rw-r--r--README.txt2
-rw-r--r--mercurial_extension_utils.egg-info/PKG-INFO4
-rw-r--r--mercurial_extension_utils.py14
-rw-r--r--setup.cfg1
-rw-r--r--setup.py2
6 files changed, 18 insertions, 9 deletions
diff --git a/PKG-INFO b/PKG-INFO
index 8d32b94..b795ef9 100644
--- a/PKG-INFO
+++ b/PKG-INFO
@@ -1,6 +1,6 @@
Metadata-Version: 1.1
Name: mercurial_extension_utils
-Version: 1.3.1
+Version: 1.3.4
Summary: Mercurial Extension Utils
Home-page: http://bitbucket.org/Mekk/mercurial-extension_utils
Author: Marcin Kasperski
@@ -186,7 +186,7 @@ Description: .. -*- mode: rst -*-
Check also `Mercurial extensions I wrote`_.
- .. _Mercurial extensions I wrote: http://mekk.bitbucket.org/mercurial.html
+ .. _Mercurial extensions I wrote: http://mekk.bitbucket.io/mercurial.html
.. _Mercurial: http://mercurial.selenic.com
.. _Dynamic Username: http://bitbucket.org/Mekk/mercurial-dynamic_username/
.. _Path Pattern: http://bitbucket.org/Mekk/mercurial-path_pattern/
diff --git a/README.txt b/README.txt
index f91bab4..47b40ab 100644
--- a/README.txt
+++ b/README.txt
@@ -178,7 +178,7 @@ Additional notes
Check also `Mercurial extensions I wrote`_.
-.. _Mercurial extensions I wrote: http://mekk.bitbucket.org/mercurial.html
+.. _Mercurial extensions I wrote: http://mekk.bitbucket.io/mercurial.html
.. _Mercurial: http://mercurial.selenic.com
.. _Dynamic Username: http://bitbucket.org/Mekk/mercurial-dynamic_username/
.. _Path Pattern: http://bitbucket.org/Mekk/mercurial-path_pattern/
diff --git a/mercurial_extension_utils.egg-info/PKG-INFO b/mercurial_extension_utils.egg-info/PKG-INFO
index f6c8d67..c2e7609 100644
--- a/mercurial_extension_utils.egg-info/PKG-INFO
+++ b/mercurial_extension_utils.egg-info/PKG-INFO
@@ -1,6 +1,6 @@
Metadata-Version: 1.1
Name: mercurial-extension-utils
-Version: 1.3.1
+Version: 1.3.4
Summary: Mercurial Extension Utils
Home-page: http://bitbucket.org/Mekk/mercurial-extension_utils
Author: Marcin Kasperski
@@ -186,7 +186,7 @@ Description: .. -*- mode: rst -*-
Check also `Mercurial extensions I wrote`_.
- .. _Mercurial extensions I wrote: http://mekk.bitbucket.org/mercurial.html
+ .. _Mercurial extensions I wrote: http://mekk.bitbucket.io/mercurial.html
.. _Mercurial: http://mercurial.selenic.com
.. _Dynamic Username: http://bitbucket.org/Mekk/mercurial-dynamic_username/
.. _Path Pattern: http://bitbucket.org/Mekk/mercurial-path_pattern/
diff --git a/mercurial_extension_utils.py b/mercurial_extension_utils.py
index df08b7a..c82499d 100644
--- a/mercurial_extension_utils.py
+++ b/mercurial_extension_utils.py
@@ -851,7 +851,12 @@ def find_repositories_below(path, check_inside=False):
yield checked
if not check_inside:
continue
- names = os.listdir(checked)
+ try:
+ names = os.listdir(checked)
+ except OSError:
+ # Things like permission errors (say, on lost+found)
+ # Let's ignorre this, better to process whatever we can
+ names = []
paths = [checked + '/' + name
for name in names if name != '.hg']
dir_paths = [item
@@ -909,7 +914,12 @@ def command(cmdtable):
"""
from mercurial import cmdutil, commands
import inspect
- command = cmdutil.command(cmdtable)
+ try:
+ from mercurial import registrar
+ command = registrar.command(cmdtable)
+ return command
+ except (ImportError, AttributeError):
+ command = cmdutil.command(cmdtable)
spec = inspect.getargspec(command)
if 'norepo' in spec[0]:
# Looks like modern mercurial with correct api, keeping
diff --git a/setup.cfg b/setup.cfg
index 861a9f5..8bfd5a1 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,5 +1,4 @@
[egg_info]
tag_build =
tag_date = 0
-tag_svn_revision = 0
diff --git a/setup.py b/setup.py
index 11eda95..cae62e3 100644
--- a/setup.py
+++ b/setup.py
@@ -2,7 +2,7 @@
from setuptools import setup, find_packages
-VERSION = '1.3.1'
+VERSION = '1.3.4'
LONG_DESCRIPTION = open("README.txt").read()
INSTALL_REQUIRES = []