summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarvin Stark <marv@der-marv.de>2009-01-15 15:28:53 +0100
committerDmitry Bogatov <KAction@debian.org>2018-11-15 15:59:21 +0000
commitc6c24d035e375be8226d9c64b0c0589ac222cf30 (patch)
tree024330b1ca1f538c52b5dce16d79f08d77b9cd17
parent362511062b205e71af3271922981fdecf00d0e9a (diff)
Import Debian changes 1.19-9
mini-httpd (1.19-9) unstable; urgency=low * Added kFreeBSD portin patch (Closes: #498368) - Thanks to Petr Salinger * Enabled CGI by default (Closes: #500708) * Fixed init.d script (Closes: #500708, #491083) * data_dir will be created if necessary (Closes: #494437) * Added example index.html * changed default data_dir to /usr/share/mini-httpd/html * Fixed typo in 03-cgi-php.dpatch * Updated Standards-Version to 3.8.0
-rw-r--r--debian/changelog14
-rw-r--r--debian/config/mini-httpd.conf5
-rw-r--r--debian/control2
-rw-r--r--debian/html/index.html10
-rw-r--r--debian/mini-httpd.init.d33
-rw-r--r--debian/mini-httpd.preinst1
-rw-r--r--debian/patches/00list1
-rw-r--r--debian/patches/03-cgi-php.dpatch2
-rw-r--r--debian/patches/04-kfreebsd.dpatch36
-rwxr-xr-xdebian/rules3
10 files changed, 89 insertions, 18 deletions
diff --git a/debian/changelog b/debian/changelog
index 0fe7bb3..10ff0b1 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,17 @@
+mini-httpd (1.19-9) unstable; urgency=low
+
+ * Added kFreeBSD portin patch (Closes: #498368)
+ - Thanks to Petr Salinger
+ * Enabled CGI by default (Closes: #500708)
+ * Fixed init.d script (Closes: #500708, #491083)
+ * data_dir will be created if necessary (Closes: #494437)
+ * Added example index.html
+ * changed default data_dir to /usr/share/mini-httpd/html
+ * Fixed typo in 03-cgi-php.dpatch
+ * Updated Standards-Version to 3.8.0
+
+ -- Marvin Stark <marv@der-marv.de> Thu, 15 Jan 2009 15:28:53 +0100
+
mini-httpd (1.19-8) unstable; urgency=low
* /etc/mini-httpd.conf:
diff --git a/debian/config/mini-httpd.conf b/debian/config/mini-httpd.conf
index d0a1b23..087ca5c 100644
--- a/debian/config/mini-httpd.conf
+++ b/debian/config/mini-httpd.conf
@@ -22,7 +22,10 @@ nochroot # no
# We are the web files stored?
# Please change this to your needs.
-data_dir=/var/www
+data_dir=/usr/share/mini-httpd/html
+
+# CGI path
+cgipat=cgi-bin/*
# Which certificate to use?
#certfile=<certfile>
diff --git a/debian/control b/debian/control
index 9fe5265..8cd3c8c 100644
--- a/debian/control
+++ b/debian/control
@@ -4,7 +4,7 @@ Priority: optional
Maintainer: Marvin Stark <marv@der-marv.de>
Build-Depends: debhelper (>= 4), dpatch, libssl-dev
Homepage: http://www.acme.com/software/mini_httpd
-Standards-Version: 3.7.3
+Standards-Version: 3.8.0
Package: mini-httpd
Architecture: any
diff --git a/debian/html/index.html b/debian/html/index.html
new file mode 100644
index 0000000..d20fbb4
--- /dev/null
+++ b/debian/html/index.html
@@ -0,0 +1,10 @@
+<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
+<html xmlns="http://www.w3.org/1999/xhtml">
+<head>
+<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
+<title>Welcome page</title>
+</head>
+<body>
+It works!
+</body>
+</html>
diff --git a/debian/mini-httpd.init.d b/debian/mini-httpd.init.d
index a9ed23b..6f70372 100644
--- a/debian/mini-httpd.init.d
+++ b/debian/mini-httpd.init.d
@@ -25,8 +25,8 @@ fi
set -e
-case "$1" in
- start)
+# Functions
+function start {
if [ "$START" = "1" ]
then
echo -n "Starting $DESC: "
@@ -37,9 +37,9 @@ case "$1" in
printf "You have to edit /etc/mini-httpd.conf and\n/etc/default/mini-httpd before running mini-httpd!\n"
exit 0
fi
- ;;
+}
- stop)
+function stop {
echo -n "Stopping $DESC: "
# Get pid number
if [ -e /var/run/$NAME.pid ]
@@ -47,7 +47,7 @@ case "$1" in
PID=`cat /var/run/$NAME.pid`
if [ -d /proc/$PID ]
then
- start-stop-daemon --stop --quiet --pidfile /var/run/$NAME.pid
+ start-stop-daemon -v --stop --quiet --oknodo --pidfile /var/run/$NAME.pid
else
# we need to remove the pidfile manually
if [ -e /var/run/$NAME.pid ]
@@ -55,21 +55,24 @@ case "$1" in
rm -f /var/run/$NAME.pid
fi
fi
+ else
+ start-stop-daemon --stop --quiet --oknodo --name $DAEMON
fi
echo "$NAME."
+}
+
+case "$1" in
+ start)
+ start
+ ;;
+
+ stop)
+ stop
;;
restart|force-reload)
- echo -n "Restarting $DESC: "
- if [ "$START" = "0" ]
- then
- start-stop-daemon --start --quiet --pidfile /var/run/$NAME.pid \
- --exec $DAEMON -- $DAEMON_OPTS
- fi
- sleep 1
- start-stop-daemon --start --quiet --pidfile \
- /var/run/$NAME.pid --exec $DAEMON -- $DAEMON_OPTS
- echo "$NAME."
+ stop
+ start
;;
*)
diff --git a/debian/mini-httpd.preinst b/debian/mini-httpd.preinst
index cac0924..2db6a0f 100644
--- a/debian/mini-httpd.preinst
+++ b/debian/mini-httpd.preinst
@@ -9,6 +9,7 @@ then
dpkg-divert --package mini-httpd --divert \
/usr/bin/htpasswd.${p} --rename /usr/bin/htpasswd
done
+
fi
#DEBHELPER#
diff --git a/debian/patches/00list b/debian/patches/00list
index b2abd9f..e8bc235 100644
--- a/debian/patches/00list
+++ b/debian/patches/00list
@@ -1,3 +1,4 @@
01-manpage.dpatch
02-makefile.dpatch
03-cgi-php.dpatch
+04-kfreebsd.dpatch
diff --git a/debian/patches/03-cgi-php.dpatch b/debian/patches/03-cgi-php.dpatch
index ddb8155..c4c8a7e 100644
--- a/debian/patches/03-cgi-php.dpatch
+++ b/debian/patches/03-cgi-php.dpatch
@@ -1,5 +1,5 @@
#!/bin/sh /usr/share/dpatch/dpatch-run
-## 02-cgi-php.dpatch by Marvin Stark <marv@der-marv.de>
+## 03-cgi-php.dpatch by Marvin Stark <marv@der-marv.de>
## Thanks to Thorsten Schmale who has written this patch.
##
## DP: mini_httpd does not run php cgi's.
diff --git a/debian/patches/04-kfreebsd.dpatch b/debian/patches/04-kfreebsd.dpatch
new file mode 100644
index 0000000..4cf3322
--- /dev/null
+++ b/debian/patches/04-kfreebsd.dpatch
@@ -0,0 +1,36 @@
+#!/bin/sh /usr/share/dpatch/dpatch-run
+## 04-kfreebsd.dpatch by Marvin Stark <marv@der-marv.de>
+## Thanks to Petr Salinger who has written this patch.
+##
+## DP: mini-httpd does not build on GNU/kFreeBSD
+
+@DPATCH@
+
+--- mini-httpd-1.19/port.h~ 2008-09-09 15:37:08.000000000 +0000
++++ mini-httpd-1.19/port.h 2008-09-09 15:37:08.000000000 +0000
+@@ -21,6 +21,9 @@
+ #elif defined(__svr4__)
+ # define OS_SysV
+ # define ARCH "SysV"
++#elif defined(__GLIBC__)
++# define OS_GLIBC
++# define ARCH "GLIBC"
+ #else
+ # define OS_UNKNOWN
+ # define ARCH "UNKNOWN"
+@@ -80,6 +83,15 @@
+ # define HAVE_INT64T
+ #endif /* OS_Linux */
+
++#ifdef OS_GLIBC
++# define HAVE_DAEMON
++# define HAVE_SETSID
++# define HAVE_WAITPID
++# define HAVE_TM_GMTOFF
++# define HAVE_SCANDIR
++# define HAVE_INT64T
++#endif /* OS_GLIBC */
++
+ #ifdef OS_Solaris
+ # define HAVE_SETSID
+ # define HAVE_WAITPID
diff --git a/debian/rules b/debian/rules
index 4a3ba8e..168299d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -37,6 +37,9 @@ install: build
SSL_INC="-I${SSL_TREE}/include/openssl" \
SSL_LIBS="-L${SSL_TREE}/lib -lssl -lcrypto"
+ # Moving index.html to its designated directory.
+ install -D -m 0644 debian/html/index.html debian/mini-httpd/usr/share/mini-httpd/html/index.html
+
# Moving mini_httpd to its designated directory.
install -D mini_httpd debian/mini-httpd/usr/sbin/mini-httpd