summaryrefslogtreecommitdiff
path: root/tests/predopost_targets/test.mk
diff options
context:
space:
mode:
Diffstat (limited to 'tests/predopost_targets/test.mk')
-rw-r--r--tests/predopost_targets/test.mk23
1 files changed, 23 insertions, 0 deletions
diff --git a/tests/predopost_targets/test.mk b/tests/predopost_targets/test.mk
new file mode 100644
index 0000000..5db4de1
--- /dev/null
+++ b/tests/predopost_targets/test.mk
@@ -0,0 +1,23 @@
+.PHONY : test_output
+test_output :
+ @set -e; \
+ \
+ { \
+ echo '=========== {pre,do,post}_recursive ============'; \
+ for t in clean cleandir install all uninstall installdirs depend; do \
+ ${MAKE} ${MAKEFLAGS} -j1 $$t | \
+ grep -v checking; \
+ done ; \
+ env MKINSTALLDIRS=no ${MAKE} ${MAKEFLAGS} -j1 install; \
+ } | env NOSORT=1 mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
+ \
+ echo '=========== {pre,do,post}_nonrec ============'; \
+ for t in bin_tar bin_targz bin_tarbz2 bin_zip bin_deb; do \
+ env INCFILE=Makefile.inc ${MAKE} ${MAKEFLAGS} -j1 $$t | \
+ grep -v checking; \
+ done ; \
+ \
+ true =========== cleandir ============; \
+ env REAL_TARGETS=1 ${MAKE} ${MAKEFLAGS} distclean > /dev/null
+
+.include <mkc.minitest.mk>