summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--MANIFEST.in1
l---------README1
-rw-r--r--README.md10
-rwxr-xr-xmkosi13
-rwxr-xr-xsetup.py6
5 files changed, 20 insertions, 11 deletions
diff --git a/MANIFEST.in b/MANIFEST.in
new file mode 100644
index 0000000..1aba38f
--- /dev/null
+++ b/MANIFEST.in
@@ -0,0 +1 @@
+include LICENSE
diff --git a/README b/README
new file mode 120000
index 0000000..42061c0
--- /dev/null
+++ b/README
@@ -0,0 +1 @@
+README.md \ No newline at end of file
diff --git a/README.md b/README.md
index b9216e8..41c146b 100644
--- a/README.md
+++ b/README.md
@@ -191,7 +191,7 @@ Create and run a bootable btrfs *GPT* image, as `foobar.raw`:
Create and run a *Fedora* image into a plain directory:
```bash
-# mkosi -t directory -o quux
+# mkosi -d fedora -t directory -o quux
# systemd-nspawn -b quux
```
@@ -236,11 +236,11 @@ EOF
# Requirements
-To use this on *Fedora*, you need:
+mkosi is packaged for various distributions: Debian, Ubuntu, Arch (in AUR), Fedora.
+It is usually easiest to use the distribution package.
+
+When not using distribution packages, for example, on *Fedora* you need:
```bash
dnf install python3 debootstrap arch-install-scripts xz btrfs-progs dosfstools edk2-ovmf
```
-
-This should work on other distributions too, as long as the
-same dependencies are available, but it's untested.
diff --git a/mkosi b/mkosi
index ca06423..1c74c5f 100755
--- a/mkosi
+++ b/mkosi
@@ -16,6 +16,8 @@ import time
import uuid
from enum import Enum
+__version__ = '1'
+
# TODO
# - squashfs root
# - volatile images
@@ -1180,7 +1182,7 @@ def process_setting(args, section, key, value):
args.read_only = parse_boolean(value)
elif key == "Compress":
if not args.compress:
- args.read_only = parse_boolean(value)
+ args.compress = parse_boolean(value)
elif key == "XZ":
if not args.xz:
args.xz = parse_boolean(value)
@@ -1245,14 +1247,17 @@ def process_setting(args, section, key, value):
return False
elif section == "Validation":
if key == "CheckSum":
- if not args.check_sum:
- args.check_sum = parse_boolean(value)
+ if not args.checksum:
+ args.checksum = parse_boolean(value)
elif key == "Sign":
if not args.sign:
args.sign = parse_boolean(value)
elif key == "Key":
if args.key is None:
args.key = value
+ elif key == "Password":
+ if args.password is None:
+ args.password = value
elif key is None:
return True
else:
@@ -1501,6 +1506,7 @@ def print_summary(args):
if args.distribution == Distribution.fedora:
sys.stderr.write(" With Documentation: " + yes_no(args.with_docs) + "\n")
+ if args.distribution in (Distribution.fedora, Distribution.debian, Distribution.ubuntu):
sys.stderr.write(" Package Cache: " + none_to_none(args.cache_path) + "\n")
sys.stderr.write(" Extra Trees: " + line_join_list(args.extra_trees) + "\n")
@@ -1523,6 +1529,7 @@ def print_summary(args):
sys.stderr.write(" Checksum: " + yes_no(args.checksum) + "\n")
sys.stderr.write(" Sign: " + yes_no(args.sign) + "\n")
sys.stderr.write(" GPG Key: " + ("default" if args.key is None else args.key) + "\n")
+ sys.stderr.write(" Password: " + ("default" if args.password is None else args.password) + "\n")
def build_image(args, workspace, run_build_script):
# If there's no build script set, there's no point in executing
diff --git a/setup.py b/setup.py
index 4fd958b..8e41779 100755
--- a/setup.py
+++ b/setup.py
@@ -7,8 +7,8 @@ setup(
version="1",
description="Create legacy-free OS images",
url="https://github.com/systemd/mkosi",
- author="Lennart Poettering",
- author_email="lennart@poettering.net",
- license="LICENSE",
+ maintainer="mkosi contributors",
+ maintainer_email="systemd-devel@lists.freedesktop.org",
+ license="LGPLv2+",
scripts=["mkosi"],
)