summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xdebian/rules8
1 files changed, 2 insertions, 6 deletions
diff --git a/debian/rules b/debian/rules
index b610a2d..1733887 100755
--- a/debian/rules
+++ b/debian/rules
@@ -10,14 +10,10 @@ export PYBUILD_NAME=mkosi
dh $@ --with python3 --buildsystem=pybuild
# need explicit target to be able to mark as phony
-build build-indep: debian/mkosi.1
- dh $@ --with python3 --buildsystem=pybuild
-
-debian/mkosi.1:
+override_dh_auto_build:
+ dh_auto_build --buildsystem=pybuild
help2man --name "Create legacy-free OS images" \
--version-string "mkosi $(DEB_VERSION_UPSTREAM)" \
--no-info \
-o debian/mkosi.1 \
./mkosi
-
-.PHONY: build