summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 5 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 812a267..d2d0145 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,7 +2,6 @@
# -*- mode: makefile; coding: utf-8 -*-
include /usr/share/cdbs/1/rules/debhelper.mk
-DEB_PYTHON_SYSTEM = pysupport
# for earlier cdbs versions
DEB_PYTHON_MODULE_PACKAGE = python-mlpy
# for cdbs >= 0.4.54
@@ -44,6 +43,7 @@ build/python-mlpy-doc:: doc
# symlinked by debhelper
install/python-mlpy-doc::
-rm docs/build/html/_static/jquery.js
+ -rm doc/_build/html/_static/underscore.js
install/python-mlpy-lib::
# move libraries into the python-mlpy-lib package
@@ -55,6 +55,9 @@ install/python-mlpy-lib::
mv $$lib $$tdir ; \
done
+binary-install/python-mlpy-lib::
+ dh_numpy
+
# we need to move libraries away first, hence dependence on -lib
# Also without this step, movemodules from pysupport would not
# move arch-indep part of the module under pyshared
@@ -64,7 +67,7 @@ install/python-mlpy:: install/python-mlpy-lib
DEB_DESTDIR = $(CURDIR)/debian/python-mlpy
# immediately useable documentation
# and exemplar data (they are small excerpts anyways)
-DEB_COMPRESS_EXCLUDE := .py .pdf .html .css .jpg .txt .js .json .rtc .par .bin
+DEB_COMPRESS_EXCLUDE := .py .pdf .html .css .jpg .txt .js .json .rtc .par .bin .inv
# Man pages
DEB_INSTALL_MANPAGES_python-mlpy := build/man/*.1
# -doc package contents