summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2013-07-11 10:56:21 -0400
committerJoey Hess <joey@kitenet.net>2013-07-11 10:56:21 -0400
commit051b613dc1aaf34b435e47acdb24ae59be6d250c (patch)
tree5184d7388580e2c7bce23a864143a35bd018b94c
parentd3510311c1b0130b00912c1bbaec82fcd8f3b74e (diff)
Fix build on Hurd. Closes: #716653 (Thanks, Pino Toscano)
-rw-r--r--debian/changelog7
-rw-r--r--ifdata.c4
-rw-r--r--parallel.c2
3 files changed, 12 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 7559ffb..cec92a2 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+moreutils (0.50) UNRELEASED; urgency=low
+
+ * Fix build on Hurd. Closes: #716653
+ (Thanks, Pino Toscano)
+
+ -- Joey Hess <joeyh@debian.org> Thu, 11 Jul 2013 10:55:52 -0400
+
moreutils (0.49) unstable; urgency=low
* ts: Fix timezone used with -i
diff --git a/ifdata.c b/ifdata.c
index 2de98a0..031bc19 100644
--- a/ifdata.c
+++ b/ifdata.c
@@ -14,6 +14,10 @@
#include <net/if.h>
#endif
+#if defined(__GNU__)
+ #include <net/if.h>
+#endif
+
#include <netinet/in.h>
#include <errno.h>
#include <fcntl.h>
diff --git a/parallel.c b/parallel.c
index d283b96..1bd796b 100644
--- a/parallel.c
+++ b/parallel.c
@@ -32,7 +32,7 @@
#include <sys/wait.h>
#include <unistd.h>
-#if defined(__FreeBSD_kernel__)
+#if !defined(WEXITED)
#define WEXITED 0
#endif