summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2013-11-04 12:28:29 -0400
committerJoey Hess <joey@kitenet.net>2013-11-04 12:28:29 -0400
commit052a77f216ce5980851b74068e29ab2e78b30f7c (patch)
tree08cc6c6d1f939c3fdc1d59c85c9cd301cdb0f35a
parent323e2f7a120823806156c6afe9d4158904802b0e (diff)
Fix ifdata to build on OS X. Thanks, Peter Eisentraut Closes: #575294
-rw-r--r--debian/changelog7
-rw-r--r--ifdata.c5
2 files changed, 12 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index e754e20..5c111b7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+moreutils (0.51) UNRELEASED; urgency=low
+
+ * Fix ifdata to build on OS X. Thanks, Peter Eisentraut
+ Closes: #575294
+
+ -- Joey Hess <joeyh@debian.org> Mon, 04 Nov 2013 12:28:04 -0400
+
moreutils (0.50) unstable; urgency=low
* Fix build on Hurd. Closes: #716653
diff --git a/ifdata.c b/ifdata.c
index 031bc19..6d7ed6f 100644
--- a/ifdata.c
+++ b/ifdata.c
@@ -18,6 +18,11 @@
#include <net/if.h>
#endif
+#if defined(__APPLE__)
+ #define s6_addr16 __u6_addr.__u6_addr16
+ #include <net/if.h>
+#endif
+
#include <netinet/in.h>
#include <errno.h>
#include <fcntl.h>