summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2012-06-04 14:22:42 +0100
committerLars Wirzenius <liw@liw.fi>2012-06-04 14:22:42 +0100
commit66a2a6ace9fb99096c2a1d0144a7b12895db59e6 (patch)
treeafbed2128eac7120dc1511a6e80987df066931b4
parent2bc2887fefba2591bd6ede3a1eabbb6c26cf7a25 (diff)
Add errno manpage
-rw-r--r--Makefile5
-rw-r--r--errno.docbook86
2 files changed, 90 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 501701f..41c9c81 100644
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,6 @@
BINS=isutf8 ifdata ifne pee sponge mispipe lckdo parallel errno
PERLSCRIPTS=vidir vipe ts combine zrun chronic
-MANS=sponge.1 vidir.1 vipe.1 isutf8.1 ts.1 combine.1 ifdata.1 ifne.1 pee.1 zrun.1 chronic.1 mispipe.1 lckdo.1 parallel.1
+MANS=sponge.1 vidir.1 vipe.1 isutf8.1 ts.1 combine.1 ifdata.1 ifne.1 pee.1 zrun.1 chronic.1 mispipe.1 lckdo.1 parallel.1 errno.1
CFLAGS=-O2 -g -Wall
INSTALL_BIN?=install -s
PREFIX=/usr
@@ -52,6 +52,9 @@ errnos.h:
echo '#include <errno.h>' > dump.c
$(CC) -E -dD dump.c | ./errnos > errnos.h
rm -f dump.c
+
+errno.1: errno.docbook
+ $(DOCBOOK2XMAN) $<
%.1: %
pod2man --center=" " --release="moreutils" $< > $@;
diff --git a/errno.docbook b/errno.docbook
new file mode 100644
index 0000000..0ddaba1
--- /dev/null
+++ b/errno.docbook
@@ -0,0 +1,86 @@
+<?xml version="1.0" encoding="utf-8"?>
+
+<!--
+
+Copyright 2012 Lars Wirzenius (liw@iki.fi)
+
+This program is free software; you can redistribute it and/or modify it
+under the terms of the GNU General Public License as published by the
+Free Software Foundation; either version 2 of the License, or (at your
+option) any later version.
+
+This program is distributed in the hope that it will be useful, but
+WITHOUT ANY WARRANTY; without even the implied warranty of
+MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General
+Public License for more details.
+
+You should have received a copy of the GNU General Public License along
+with this program; if not, write to the Free Software Foundation, Inc.,
+59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+
+-->
+
+<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook V4.4//EN"
+"file:///usr/share/xml/docbook/schema/dtd/4.4/docbookx.dtd"
+[]>
+
+<refentry>
+ <refentryinfo>
+ <address>
+ <email>liw@liw.fi</email>
+ </address>
+ <author>
+ <firstname>Lars</firstname>
+ <surname>Wirzenius</surname>
+ </author>
+ <date>2012-06-04</date>
+ </refentryinfo>
+
+ <refmeta>
+ <refentrytitle>errno</refentrytitle>
+ <manvolnum>1</manvolnum>
+ </refmeta>
+
+ <refnamediv>
+ <refname>errno</refname>
+ <refpurpose>look up errno names and descriptions</refpurpose>
+ </refnamediv>
+
+ <refsynopsisdiv>
+ <cmdsynopsis>
+ <command>errno</command>
+ <arg choice="req"><replaceable>name-or-code</replaceable></arg>
+ </cmdsynopsis>
+ </refsynopsisdiv>
+
+ <refsect1>
+ <title>DESCRIPTION</title>
+
+ <para><command>errno</command> looks up errno macro names,
+ errno codes, and the corresponding descriptions. For example,
+ if given <literal>ENOENT</literal> on a Linux system, it
+ prints out the code 2 and the description "No such file or directory".
+ If given the code 2, it printes <literal>ENOENT</literal>
+ and the same description.</para>
+
+ </refsect1>
+
+ <refsect1>
+ <title>AUTHOR</title>
+ Lars Wirzenius
+ <para>
+
+ </para>
+ </refsect1>
+
+ <refsect1>
+ <title>SEE ALSO</title>
+
+ <para>
+ <citerefentry>
+ <refentrytitle>errno</refentrytitle><manvolnum>3</manvolnum>
+ </citerefentry>
+ </para>
+
+ </refsect1>
+</refentry>