summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2010-02-23 15:58:54 -0500
committerJoey Hess <joey@gnu.kitenet.net>2010-02-23 15:58:54 -0500
commit6ec9f75d9c41ff60acf1e3362321e76b699706b1 (patch)
tree51ecafaa6e63d7436bc0b2f94f8a92c87e0a19dd
parentb04468bb912d9635fe5f3965b15678add8046f58 (diff)
zrun: Add support for .xz files.
-rw-r--r--debian/changelog7
-rwxr-xr-xzrun5
2 files changed, 7 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index 599ad9d..b397564 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,14 +1,15 @@
-moreutils (0.39) UNRELEASED; urgency=low
+moreutils (0.39) unstable; urgency=low
- * Cap sillyness. Closes: #570815
* parallel: Fix exit code handling when commands are specified after --
* parallel: Make -j 0 do something reasonable (start all jobs at once).
* parallel: Fix to really avoid running new jobs when load is too high.
* parallel: Fix logic error in code handling -l that could make parallel
return a bogus 255 exit code when all jobs succeeded. Closes: #569617
* parallel: Allow a decimal load value to be specified with -l
+ * Caps sillyness. Closes: #570815
+ * zrun: Add support for .xz files.
- -- Joey Hess <joeyh@debian.org> Sun, 21 Feb 2010 13:16:10 -0500
+ -- Joey Hess <joeyh@debian.org> Tue, 23 Feb 2010 15:51:26 -0500
moreutils (0.38) unstable; urgency=low
diff --git a/zrun b/zrun
index 50026eb..98d1445 100755
--- a/zrun
+++ b/zrun
@@ -17,7 +17,7 @@ arguments of the command to be transparently uncompressed to temp files
This is a quick way to run a command that does not itself support
compressed files, without manually uncompressing the files.
-The following compression types are supported: gz bz2 Z lzma lzo
+The following compression types are supported: gz bz2 Z xz lzma lzo
If zrun is linked to some name beginning with z, like zprog, and the link is
executed, this is equivalent to executing "zrun prog".
@@ -58,9 +58,10 @@ else {
my @argument;
my %child;
foreach my $argument (@ARGV) {
- if ($argument =~ m{^(.*/)?([^/]*)\.(gz|Z|bz2|lzo|lzma)$}s) {
+ if ($argument =~ m{^(.*/)?([^/]*)\.(gz|Z|bz2|xz|lzo|lzma)$}s) {
my $suffix = "-$2";
my @preprocess = $3 eq "bz2" ? qw(bzip2 -d -c) :
+ $3 eq "xz" ? qw(xz -d -c) :
$3 eq "lzo" ? qw(lzop -d -c) :
$3 eq "lzma" ? qw(lzma -d -c) : qw(gzip -d -c);