summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenjamin Drung <bdrung@ubuntu.com>2009-09-24 13:01:34 +0200
committerBenjamin Drung <bdrung@ubuntu.com>2009-09-24 13:01:34 +0200
commit788556e8570cb03752d0936c991c086a8e5cfd5d (patch)
tree93931ba4a7ac5e0947d66c4753d68a8114422376
parentd12c31aa436ff1e1b773d71d508a0cec817b72d6 (diff)
- support different types of install.rdf files (LP: #422898)
- update src/xpi.mk
-rw-r--r--debian/changelog4
-rw-r--r--src/xpi.mk10
2 files changed, 10 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index 1e466a5..d61449e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -32,6 +32,8 @@ mozilla-devscripts (0.16) UNRELEASED; urgency=low
- update src/xpi.mk
- add sanity check for xpi file and fail with useful error messages
- update src/xpi.mk
+ - support different types of install.rdf files (LP: #422898)
+ - update src/xpi.mk
* packaging:
- allow uploads done by Debian Maintainers
@@ -53,7 +55,7 @@ mozilla-devscripts (0.16) UNRELEASED; urgency=low
field in debian/control for the target package
- update src/xpi.mk
- -- Benjamin Drung <bdrung@ubuntu.com> Wed, 23 Sep 2009 23:06:27 +0200
+ -- Benjamin Drung <bdrung@ubuntu.com> Thu, 24 Sep 2009 12:58:48 +0200
mozilla-devscripts (0.15) unstable; urgency=low
diff --git a/src/xpi.mk b/src/xpi.mk
index 6cad17d..6289b3c 100644
--- a/src/xpi.mk
+++ b/src/xpi.mk
@@ -139,7 +139,7 @@ Ubuntu_packages := abrowser-3.5 firefox-3.0 firefox-3.5 thunderbird seamonkey co
# 1- target app id
# 2- maxVersion | minVersion
# 3- extension dir
-TARGET_VERSION = $(shell xpath -q -e '//em:targetApplication/Description[em:id="$(1)" or @em:id="$(1)"]/em:$(2)/text() | //em:targetApplication/Description[em:id="$(1)" or @em:id="$(1)"]/@em:$(2)' $(3)/install.rdf)
+TARGET_VERSION = $(shell xpath -q -e '//em:targetApplication/Description[em:id="$(1)" or @em:id="$(1)"]/em:$(2)/text() | //em:targetApplication/Description[em:id="$(1)" or @em:id="$(1)"]/@em:$(2) | //RDF:Description[@em:id="$(1)"]/@em:$(2)' $(3)/install.rdf | sed -e 's/.*"\(.*\)"/\1/')
# call parameters_
# 1- target app id
@@ -184,13 +184,17 @@ XPI_BASE_FILE = $(notdir $(XPI_FILE))
ifneq (,$(MOZ_XPI_EMID))
XPI_EMID = $(MOZ_XPI_EMID)
else
-XPI_EMID = $(shell xpath -e '/node()/Description/em:id/text()' $(1)/install.rdf 2>/dev/null)
+XPI_EMID = $(sort $(shell xpath -q -e '/node()/Description/em:id/text() | //RDF:Description[@RDF:about="urn:mozilla:install-manifest"]/em:id/text()' $(1)/install.rdf 2>/dev/null) \
+ $(shell xpath -q -e '//RDF:Description[@RDF:about="urn:mozilla:install-manifest"]/@em:id' $(1)/install.rdf 2>/dev/null | sed -e 's/.*"\(.*\)"/\1/'))
endif
ifeq (,$(MOZ_XPI_DISABLE_AUTOLINKS))
+RDF_RESOURCES = $(shell xpath -q -e '//em:targetApplication/@RDF:resource' $(1)/install.rdf | sed -e 's/.*="\(.*\)"/\1/')
+
XPI_TARGET_EMIDs = \
$(shell xpath -q -e '//em:targetApplication//@em:id' $(1)/install.rdf 2>/dev/null | sed -e 's/.*"\(.*\)"/\1/') \
- $(shell xpath -q -e '//em:targetApplication//em:id/text()' $(1)/install.rdf 2>/dev/null)
+ $(shell xpath -q -e '//em:targetApplication//em:id/text()' $(1)/install.rdf 2>/dev/null) \
+ $(foreach resource,$(RDF_RESOURCES),$(shell xpath -q -e '//RDF:Description[@RDF:about="$(resource)"]/@em:id' $(1)/install.rdf 2>/dev/null | sed -e 's/.*"\(.*\)"/\1/'))
endif
# local vars