summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2016-07-19 15:39:59 -0700
committerSean Whitton <spwhitton@spwhitton.name>2016-07-19 15:46:56 -0700
commitc682d365d48e5411547c690d647eaad98c9ac8b5 (patch)
tree04ec6c9d5e52dd98d4c3f1e88fda72a771154894
parent1b0836ad5163ddb00fa9b2475f422dd581fd942c (diff)
xul_ext.pm: dh_auto_install passes extra params
-rw-r--r--debian/changelog8
-rw-r--r--perl/Debian/Buildsystem/xul_ext.pm7
2 files changed, 14 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index be32f37..4bca14e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+mozilla-devscripts (0.47) UNRELEASED; urgency=low
+
+ * When using the xul_ext dh buildsystem, params passed to
+ dh_auto_install after '--' are now passed on to install-xpi.
+ As dh_auto_install(1) claims.
+
+ -- Sean Whitton <spwhitton@spwhitton.name> Tue, 19 Jul 2016 15:36:52 -0700
+
mozilla-devscripts (0.46) unstable; urgency=medium
* Fix generating versions in light of Icedove's new 1: epoch in Debian.
diff --git a/perl/Debian/Buildsystem/xul_ext.pm b/perl/Debian/Buildsystem/xul_ext.pm
index 89c8763..983323d 100644
--- a/perl/Debian/Buildsystem/xul_ext.pm
+++ b/perl/Debian/Buildsystem/xul_ext.pm
@@ -32,7 +32,12 @@ sub build {
sub install {
my $this=shift;
- $this->doit_in_sourcedir("install-xpi", $dh{FIRSTPACKAGE} . ".xpi");
+ # the first param dh_auto_install gives us is the source
+ # directory; if we shift it off, @_ contains everything passed
+ # by the user after '--', which we pass to install-xpi as
+ # dh_auto_install(1) claims
+ shift;
+ $this->doit_in_sourcedir("install-xpi", @_, $dh{FIRSTPACKAGE} . ".xpi");
}
sub clean {