summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenjamin Drung <bdrung@ubuntu.com>2009-08-22 14:14:26 +0200
committerBenjamin Drung <bdrung@ubuntu.com>2009-08-22 14:14:26 +0200
commitea08fb9348da01641985674daea4f5c435f13c6d (patch)
tree53dd1541f5afe581ac7f406d65ccb5a146f0be53
parentbfe05a21382037382616a383ed787b2d4cfe1ab9 (diff)
* xpi.mk:
- List all phony target and run dh_clean for all packages. These changes makes it possible to use xpi.mk without cdbs in a simple way. - update src/xpi.mk
-rw-r--r--debian/changelog9
-rw-r--r--src/xpi.mk4
2 files changed, 12 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 3f6b4d0..ea83fa9 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+mozilla-devscripts (0.16) UNRELEASED; urgency=low
+
+ * xpi.mk:
+ - List all phony target and run dh_clean for all packages. These changes
+ makes it possible to use xpi.mk without cdbs in a simple way.
+ - update src/xpi.mk
+
+ -- Benjamin Drung <bdrung@ubuntu.com> Sat, 22 Aug 2009 14:08:50 +0200
+
mozilla-devscripts (0.15) unstable; urgency=low
[ Benjamin Drung <bdrung@ubuntu.com> ]
diff --git a/src/xpi.mk b/src/xpi.mk
index b7e186d..0a0d0fc 100644
--- a/src/xpi.mk
+++ b/src/xpi.mk
@@ -204,6 +204,7 @@ stamp-installlinks-%:
stamp-autolinks: $(foreach mozilla,$(MOZ_XPI_MOZILLA_DIRS),stamp-installlinks-$(mozilla))
$(foreach id,$(call XPI_TARGET_EMIDs,$(TEMPDIR)),dh_link -p$(MOZ_EXTENSION_PKG) /usr/share/$(MOZ_EXTENSION_PKG) /usr/lib/mozilla/extensions/$(id)/$(call XPI_EMID,$(TEMPDIR));)
+ touch $@
stamp-install-%: stamp-autolinks
dh_install -p$(MOZ_EXTENSION_PKG) $(wildcard $(TEMPDIR)/*) /usr/share/$(MOZ_EXTENSION_PKG)
@@ -223,7 +224,7 @@ ifneq (,$(MOZ_EXTENSION_PKG))
xpi-install: stamp-extension-install stamp-xpi-depends
xpi-clean:
- dh_clean -p$(MOZ_EXTENSION_PKG)
+ dh_clean
-rm -f stamp-extension-install \
stamp-* \
$(NULL)
@@ -240,3 +241,4 @@ xpi-clean:
exit 2
endif
+.PHONY: xpi-install xpi-clean