summaryrefslogtreecommitdiff
path: root/src/Makefile
diff options
context:
space:
mode:
authorFabien Tassin <fta@sofaraway.org>2008-01-04 01:19:43 +0100
committerFabien Tassin <fta@sofaraway.org>2008-01-04 01:19:43 +0100
commit776d906107cf3163959acc041edfcb4227a0ed71 (patch)
tree3a8da8d20246ce3e8eb861808962100f81150951 /src/Makefile
parent2fe338df2283640ebbdc378000d6c224c1aeb54f (diff)
* Move patches for mozilla/client.mk inside src/ as they were previously
missed at install time. This will prevent confusions with other future scripts * Drop Changelog.txt, use debian/changelog instead
Diffstat (limited to 'src/Makefile')
-rw-r--r--src/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/Makefile b/src/Makefile
index bf53346..7f5158a 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -40,6 +40,7 @@ extra_mk_files = \
cat $< | sed \
-e "s|^\(include\) \(.*\)\.in|\1 $(DATADIR)/\2|" \
-e "s|^\(MOZCLIENT_EXCLUDE_SCRIPT.*=[ ][ ]*\)\(.*/\)\(.*\)|\1$(DATADIR)/\3|" \
+ -e "s|^\(MOZCLIENT_PATCHES.*=[ ][ ]*\)\(.*/\)\(.*\)|\1$(DATADIR)/\3|" \
> $@
chmod 644 $@
@@ -49,6 +50,8 @@ install: $(mk_files) $(extra_mk_files)
install -m 755 -d $(DESTDIR)$(DATADIR)
install -m 644 $^ $(DESTDIR)$(DATADIR)
chmod 755 $(DESTDIR)$(DATADIR)/*.sh
+ install -m 755 -d $(DESTDIR)$(DATADIR)/patches
+ install -m 644 $(wildcard ../patches/*) $(DESTDIR)$(DATADIR)/patches
clean:
rm -f $(mk_files)