summaryrefslogtreecommitdiff
path: root/src/thunderbird-2.0.mk.in
diff options
context:
space:
mode:
authorFabien Tassin <fta@sofaraway.org>2008-06-02 14:02:07 +0200
committerFabien Tassin <fta@sofaraway.org>2008-06-02 14:02:07 +0200
commit68c81fa9645d3cde57e775dae4ee28c99476ea1f (patch)
tree3d5a72c74271439f5c5a2097910cacb8c2585b2a /src/thunderbird-2.0.mk.in
parent3df66ad3d14674a57c881e1c7b696388276676e8 (diff)
* [mozclient] Full refactoring of mozclient. It is now written in object-oriented Perl.
The makefile version was getting difficult to extend and to maintain. We now have a base class and a set of VCS classes inheriting for it. - add src/mozclient.pl.in - add src/mozclient/${projects}.conf - move src/patches to src/mozclient/patches - update src/${projects}.mk.in - update src/Makefile - update README * [mozclient] nspr and nss are now using a dynamic tag. They used to fetch HEAD which made them tricky to distribute. Now, we take NSPR_CO_TAG and NSS_CO_TAG from mozilla/client.mk (from HEAD or from a tag) and we assign a version like nss-3.12.0.3+1.9~cvs without trailling cvs date (as it's a taggued nss), or nss-3.12.0.3+1.9 when using a taggued mozilla/client.mk - update src/mozclient.pl.in - update src/mozclient/{nspr,nss}.conf
Diffstat (limited to 'src/thunderbird-2.0.mk.in')
-rw-r--r--src/thunderbird-2.0.mk.in13
1 files changed, 2 insertions, 11 deletions
diff --git a/src/thunderbird-2.0.mk.in b/src/thunderbird-2.0.mk.in
index 1c63cc7..1e1a01f 100644
--- a/src/thunderbird-2.0.mk.in
+++ b/src/thunderbird-2.0.mk.in
@@ -1,6 +1,6 @@
# -*- mode: makefile; coding: utf-8 -*-
-# Copyright (c) 2007 Fabien Tassin <fta@sofaraway.org>
+# Copyright (c) 2007-2008 Fabien Tassin <fta@sofaraway.org>
# Description: Project Thunderbird 2.0
#
# This program is free software; you can redistribute it and/or
@@ -17,15 +17,6 @@
# with this program; if not, write to the Free Software Foundation, Inc.,
# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-MOZCLIENT_TARGET := thunderbird-2.0-orig
-MOZCLIENT_APPNAME := thunderbird
-MOZCLIENT_PROJECT := mail
-MOZCLIENT_BRANCH := MOZILLA_1_8_BRANCH
-MOZCLIENT_FILE := mozilla/mail/config/version.txt
-MOZCLIENT_GETVERSION := tail -1 $(MOZCLIENT_FILE) | sed -e 's/pre//; s/\([ab]\)\([0-9]*\)/~\1\2/'
-MOZCLIENT_URL := 'http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=MOZILLA_1_8_0_BRANCH&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2007-12-01+00%3A00%3A00&maxdate=2017-12-10+00%3A00%3A00&cvsroot=%2Fcvsroot'
-MOZCLIENT_GETDATE = wget -O - -q --read-timeout=10 --user-agent='' --tries=3 $(MOZCLIENT_URL) 2> /dev/null | grep "href='http://webtools" | head -1 | tr '<>' '@' | cut -d@ -f5 | tr -d ':-' | sed -e 's/&nbsp;/t/'
-MOZCLIENT_EMBEDDED := 1
-MOZCLIENT_WANTMOZDIR := 1
+MOZCLIENT_PROJECTNAME := thunderbird-2.0
include mozclient.mk.in