summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorBenjamin Drung <bdrung@ubuntu.com>2009-08-06 03:31:11 +0200
committerBenjamin Drung <bdrung@ubuntu.com>2009-08-06 03:31:11 +0200
commitdb2b2dcc551d426d4ab0b9c4ce74f1d209b06f44 (patch)
tree283aecc83897c8151b1635e6612368f8c500b7a1 /src
parent2c5a247ce70647cf38908e9b459c9d68838b3fa8 (diff)
- make MOZ_EXTENSION_PKG optional; if this variable is unset, the first
binary package listed in debian/control will be used - update src/xpi.mk
Diffstat (limited to 'src')
-rw-r--r--src/xpi.mk8
1 files changed, 6 insertions, 2 deletions
diff --git a/src/xpi.mk b/src/xpi.mk
index 820605e..cfe2aaf 100644
--- a/src/xpi.mk
+++ b/src/xpi.mk
@@ -24,8 +24,10 @@
# Usage: include this file in your cdbs debian/rules file and define the
# following variables:
#
-# MOZ_EXTENSION_PKG (MANDATORY):
-# define the binary package name used to ship this xpi
+# MOZ_EXTENSION_PKG (OPTIONAL):
+# if defined the given binary package name is used to ship this
+# xpi; otherwise the first binary package listed in debian/control
+# is used
#
# MOZ_XPI_FILE (OPTIONAL):
# if defined the given .xpi file is used; otherwise we try to
@@ -135,6 +137,8 @@ MOZ_XPI_BUILD_COMMAND ?= med-xpi-pack $(CURDIR) $(MOZ_EXTENSION_PKG).xpi;
XPI_DEPENDS = $(sort $(foreach id,$(call XPI_TARGET_EMIDs,$(TEMPDIR)), \
$(foreach package,$(packages_$(id)),$(call CHECK_VERSION,$(id),$(package)))))
+MOZ_EXTENSION_PKG ?= $(strip $(shell grep ^Package: debian/control | head -n 1 | sed "s/^Package://"))
+
TEMPDIR := temp-xpi-unpacked
ifneq (,$(MOZ_XPI_FILE))