summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--README1
-rw-r--r--debian/changelog5
-rwxr-xr-xsrc/mozclient.pl3
-rw-r--r--src/mozclient/lib/MozClient/VCS.pm4
4 files changed, 10 insertions, 3 deletions
diff --git a/README b/README
index 9affe55..57b89c2 100644
--- a/README
+++ b/README
@@ -80,6 +80,7 @@ as .conf files. They contain the following parameters:
- MOZCLIENT_FILE (mandatory): source file containing the version
- MOZCLIENT_GETVERSION (mandatory): how to transform the version
- MOZCLIENT_GETDATE (mandatory): get the last commit date for the project
+- MOZCLIENT_SEPARATOR (optional): separator between version and date (default: ~)
- MOZCLIENT_EMBEDDED (optional): create an embedded tarball (default: 0)
- MOZCLIENT_WANTMOZDIR (optional): should the root dir be 'mozilla'?
(default: 0 unless MOZCLIENT_EMBEDDED=1)
diff --git a/debian/changelog b/debian/changelog
index a187033..6a00ae8 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -27,6 +27,11 @@ mozilla-devscripts (0.09) UNRELEASED; urgency=low
- update src/mozclient.pl
- update src/src/mozclient/*.conf
- update README
+ + add optional MOZCLIENT_SEPARATOR to specify what we want between
+ date and revision in the version (default to ~)
+ - update src/mozclient.pl
+ - update src/mozclient/lib/MozClient/VCS.pm
+ - update README
+ add support for svn
- add src/mozclient/lib/MozClient/Subversion.pm
- update src/mozclient.pl
diff --git a/src/mozclient.pl b/src/mozclient.pl
index 160ece7..591ba86 100755
--- a/src/mozclient.pl
+++ b/src/mozclient.pl
@@ -50,12 +50,13 @@ my $work_dir = "mozclient-tmp";
my @conf_mandatory = qw(MOZCLIENT_APPNAME MOZCLIENT_FILE MOZCLIENT_GETVERSION
MOZCLIENT_GETDATE MOZCLIENT_VCS MOZCLIENT_VCS_LOC);
my @conf_optional = qw(MOZCLIENT_MODULES MOZCLIENT_PROJECT MOZCLIENT_BRANCH
- MOZCLIENT_POSTCOCMD MOZCLIENT_EMBEDDED
+ MOZCLIENT_POSTCOCMD MOZCLIENT_EMBEDDED MOZCLIENT_SEPARATOR
MOZCLIENT_WANTMOZDIR MOZCLIENT_WANTPATCH
MOZCLIENT_DYNTAG MOZCLIENT_DYNTAG_FILES);
my @conf_list = qw(MOZCLIENT_FILE);
my $defaults = {
+ 'MOZCLIENT_SEPARATOR' => '~',
'MOZCLIENT_EXCLUDE_SCRIPT' => 'remove.binonly.sh',
'MOZILLA_CLIENT' => 'mozilla/client.mk',
'MOZCLIENT_PATCHES' => "$patches_dir",
diff --git a/src/mozclient/lib/MozClient/VCS.pm b/src/mozclient/lib/MozClient/VCS.pm
index c1ed7d5..9cddbf8 100644
--- a/src/mozclient/lib/MozClient/VCS.pm
+++ b/src/mozclient/lib/MozClient/VCS.pm
@@ -305,8 +305,8 @@ sub pack {
else {
$self->chdir($self->work_dir);
chomp($tversion = `$self->{'MOZCLIENT_GETVERSION'}`);
- $tversion .= '~' . $self->{'MOZCLIENT_VCS'} . $self->{'have_date'}
- unless defined $self->{'want_tag'};
+ $tversion .= $self->{'MOZCLIENT_SEPARATOR'} . $self->{'MOZCLIENT_VCS'} .
+ $self->{'have_date'} unless defined $self->{'want_tag'};
$self->LOG2("\$ tversion=`" . $self->{'MOZCLIENT_GETVERSION'} .
"` # => $tversion");
$self->chdir("..");