summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog8
-rwxr-xr-xsrc/dh_xul-ext4
-rwxr-xr-xsrc/install-xpi2
3 files changed, 12 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index fc81706..29798da 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+mozilla-devscripts (0.25) UNRELEASED; urgency=low
+
+ * Fix additional quotation marks in extension ID (LP: #674171).
+ - update src/dh_xul-ext
+ - update src/install-xpi
+
+ -- Benjamin Drung <bdrung@ubuntu.com> Mon, 15 Nov 2010 23:16:56 +0100
+
mozilla-devscripts (0.24) unstable; urgency=low
* Drop packages that are transitional or removed in Ubuntu maverick.
diff --git a/src/dh_xul-ext b/src/dh_xul-ext
index 8447e01..58aa8d5 100755
--- a/src/dh_xul-ext
+++ b/src/dh_xul-ext
@@ -65,7 +65,9 @@ def get_supported_apps(script_name, xul_apps, install_rdf, package, verbose=Fals
results = query.execute(model)
# append to id_max_min tripe to array
for target in results:
- id_max_min.append (( str(target["id"]), str(target["max"]), str (target["min"]) ))
+ id_max_min.append ((target["id"].literal_value["string"],
+ target["max"].literal_value["string"],
+ target["min"].literal_value["string"]))
if verbose:
print "%s: %s supports %i XUL application(s):" % (script_name, package, len(id_max_min))
diff --git a/src/install-xpi b/src/install-xpi
index 3d657ad..1235047 100755
--- a/src/install-xpi
+++ b/src/install-xpi
@@ -42,7 +42,7 @@ def get_query_field_id_as_list(rdf_path, query_string):
query = RDF.Query("PREFIX em: <http://www.mozilla.org/2004/em-rdf#> " + query_string, query_language="sparql")
results = query.execute(model)
for result in results:
- ret.append(str(result["id"]))
+ ret.append(result["id"].literal_value["string"])
return ret