summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog4
-rw-r--r--src/xpi.mk9
2 files changed, 12 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index a586270..6fbe494 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -9,6 +9,8 @@ mozilla-devscripts (0.19) UNRELEASED; urgency=low
- update src/xpi.mk
- drop support for deprecated MOZ_EXT_NAME and MOZ_XPI_MOZILLA_DIRS variable
- update src/xpi.mk
+ - add new MOZ_XPI_INSTALL_DIRECTORY variable
+ - update src/xpi.mk
* med-xpi-{pack,unpack}:
- Drop med- prefix.
- rename man/med-xpi-{pack,unpack}.1 to man/xpi-{pack,unpack}.1
@@ -72,7 +74,7 @@ mozilla-devscripts (0.19) UNRELEASED; urgency=low
- update src/dh_xul-ext
- update debian/control
- -- Benjamin Drung <bdrung@ubuntu.com> Fri, 08 Jan 2010 01:46:53 +0100
+ -- Benjamin Drung <bdrung@ubuntu.com> Fri, 08 Jan 2010 02:07:43 +0100
mozilla-devscripts (0.18) unstable; urgency=low
diff --git a/src/xpi.mk b/src/xpi.mk
index a929c45..d7e8467 100644
--- a/src/xpi.mk
+++ b/src/xpi.mk
@@ -65,6 +65,11 @@
# permission of the files will be set to 644 and the permissions
# of scripts (files containing a shebang) will be set to 755.
#
+# MOZ_XPI_INSTALL_DIRECTORY (OPTIONAL):
+# The xpi file will be installed in the specified directory.
+# This directory must be an absolute path. Use this parameter
+# with care.
+#
# Unused variables (can be removed):
#
# MOZ_XPI_EMID (OPTIONAL):
@@ -88,6 +93,10 @@ ifneq (,$(MOZ_XPI_PRESERVE_PERMISSIONS))
install_xpi_extra_parameter += --preserve-permissions
endif
+ifneq (,$(MOZ_XPI_INSTALL_DIRECTORY))
+install_xpi_extra_parameter += -i $(MOZ_XPI_INSTALL_DIRECTORY)
+endif
+
ifeq ($(origin MOZ_XPI_DOCUMENTED_LICENSE_FILES),undefined)
install_xpi_extra_parameter += --remove-license-files
else