summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rw-r--r--man/med-xpi-pack.134
-rw-r--r--man/med-xpi-unpack.134
-rw-r--r--src/Makefile2
4 files changed, 77 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index f093448..7f9e58e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,6 @@
mozilla-devscripts (0.15) UNRELEASED; urgency=low
+ [ Benjamin Drung <bdrung@ubuntu.com> ]
* packaging:
- break and sort Depends and Suggests
- update debian/control
@@ -23,6 +24,12 @@ mozilla-devscripts (0.15) UNRELEASED; urgency=low
- add man/moz-version.1
- update src/Makefile
+ [ Sasa Bodiroza <jazzva@gmail.com> ]
+ * med-xpi-{pack,unpack}:
+ - wrote man page for med-xpi-{pack,unpack}
+ - add man/med-xpi-{pack,unpack}.1
+ - update src/Makefile
+
-- Benjamin Drung <bdrung@ubuntu.com> Wed, 12 Aug 2009 02:21:37 +0200
mozilla-devscripts (0.14) unstable; urgency=low
diff --git a/man/med-xpi-pack.1 b/man/med-xpi-pack.1
new file mode 100644
index 0000000..4f42fdd
--- /dev/null
+++ b/man/med-xpi-pack.1
@@ -0,0 +1,34 @@
+.TH MED-XPI-PACK "1" "13 August 2009"
+
+.SH NAME
+med-xpi-pack \- pack a directory to a XPI file
+
+.SH SYNOPSIS
+\fBmed-xpi-pack\fR <\fBinput_directory\fR> <\fBoutput_XPI_file\fR>
+
+.SH DESCRIPTION
+\fBmed-xpi-pack\fR packs a directory to a XPI file. It takes in consideration the unpacked JAR files, which are unpacked during the call of med-xpi-unpack script, in order to be able to distribute them through the repositories.
+.LP
+It is distributed as a part of mozilla-devscripts package, and is automatically called during the build process of Mozilla extension package, if the package includes xpi.mk script in debian/rules file.
+
+
+.SH OPTIONS
+.TP
+None.
+
+.SH ENVIRONMENT VARIABLES
+.TP
+None.
+
+.SH EXAMPLE
+.TP
+med-xpi-pack ubufox ubufox.xpi
+Packs the contents of the directory ubufox to file ubufox.xpi.
+
+.SH SEE ALSO
+\fBmed-xpi-unpack\fR
+
+.SH AUTHOR
+\fBmed-xpi-pack\fR was written by Alexander Sack <asac@ubuntu.com> and Sasa Bodiroza <jazzva@gmail.com>, and this manual page by Sasa Bodiroza <jazzva@gmail.com>.
+
+Both are released under the GNU General Public License, version 2 or later.
diff --git a/man/med-xpi-unpack.1 b/man/med-xpi-unpack.1
new file mode 100644
index 0000000..ef41c07
--- /dev/null
+++ b/man/med-xpi-unpack.1
@@ -0,0 +1,34 @@
+.TH MED-XPI-UNPACK "1" "13 August 2009"
+
+.SH NAME
+med-xpi-unpack \- unpack a XPI file to a directory
+
+.SH SYNOPSIS
+\fBmed-xpi-unpack\fR <\fBinput_XPI_file\fR> <\fBoutput_directory\fR>
+
+.SH DESCRIPTION
+\fBmed-xpi-pack\fR unpacks a XPI file to the specified output directory. It takes in consideration JAR files, which are usually shipped inside XPI files, and unpacks them, in order to be able to distribute them through the repositories. The unpacked JAR files are packed during build process on call of med-xpi-pack script.
+.LP
+It is distributed as a part of mozilla-devscripts package. It should be called by developer, when the XPI file needs to be unpacked during packaging.
+
+
+.SH OPTIONS
+.TP
+None.
+
+.SH ENVIRONMENT VARIABLES
+.TP
+None.
+
+.SH EXAMPLE
+.TP
+med-xpi-unpack ubufox.xpi ubufox
+Unpacks the contents of ubufox.xpi to directory ubufox.
+
+.SH SEE ALSO
+\fBmed-xpi-pack\fR
+
+.SH AUTHOR
+\fBmed-xpi-unpack\fR was written by Alexander Sack <asac@ubuntu.com> and Sasa Bodiroza <jazzva@gmail.com>, and this manual page by Sasa Bodiroza <jazzva@gmail.com>.
+
+Both are released under the GNU General Public License, version 2 or later.
diff --git a/src/Makefile b/src/Makefile
index 3149cc6..a34d2c1 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -88,6 +88,8 @@ install: $(subst_files) $(extra_files) $(foreach dir,$(extra_dirs),$(wildcard $(
install-man:
install -D -m 644 ../man/moz-version.1 $(DESTDIR)$(MANDIR)/man1/moz-version.1
+ install -D -m 644 ../man/med-xpi-pack.1 $(DESTDIR)$(MANDIR)/man1/med-xpi-pack.1
+ install -D -m 644 ../man/med-xpi-unpack.1 $(DESTDIR)$(MANDIR)/man1/med-xpi-unpack.1
clean:
rm -f $(subst_files)