summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rw-r--r--src/xpi.mk11
2 files changed, 12 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 7e567e9..e8ab866 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -6,6 +6,8 @@ mozilla-devscripts (0.19) UNRELEASED; urgency=low
- update src/xpi.mk
- combine xpath commands to one command
- update src/xpi.mk
+ - add target print-vars for debugging purpose
+ - update src/xpi.mk
-- Benjamin Drung <bdrung@ubuntu.com> Wed, 02 Dec 2009 18:06:28 +0100
diff --git a/src/xpi.mk b/src/xpi.mk
index 86ce770..d4f6579 100644
--- a/src/xpi.mk
+++ b/src/xpi.mk
@@ -228,4 +228,13 @@ ifneq (,$(MOZ_XPI_BUILD_COMMAND))
rm -f *.xpi
endif
-.PHONY: clean xpi-install
+# debug target
+print-vars:
+ @echo "install_dir: $(install_dir)"
+ @echo "XPI_EMID: $(XPI_EMID)"
+ @echo "RDF_RESOURCES: $(RDF_RESOURCES)"
+ @echo "XPI_TARGET_EMIDs: $(XPI_TARGET_EMIDs)"
+ @echo "XPI_RECOMMENDS: $(XPI_RECOMMENDS)"
+ @echo "packages: $(foreach id,$(XPI_TARGET_EMIDs),$(packages_$(id)))"
+
+.PHONY: clean xpi-install print-vars