summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--src/mozclient.mk.in4
-rw-r--r--src/mozclient/lib/MozClient/VCS.pm3
-rwxr-xr-xsrc/mozclient/mozclient.pl2
3 files changed, 9 insertions, 0 deletions
diff --git a/src/mozclient.mk.in b/src/mozclient.mk.in
index 49574c9..7f2dff2 100644
--- a/src/mozclient.mk.in
+++ b/src/mozclient.mk.in
@@ -44,6 +44,10 @@ ifdef DEBIAN_KEEP_VCS
ARGS += -p
endif
+ifdef MOZCLIENT_EMBEDDED
+ ARGS += -e
+endif
+
list-tags:
perl $(MOZDEVSCRIPT_DIR)/mozclient.pl$(EXT) -l $(MOZCLIENT_PROJECTNAME)
diff --git a/src/mozclient/lib/MozClient/VCS.pm b/src/mozclient/lib/MozClient/VCS.pm
index d97e45c..d2dd318 100644
--- a/src/mozclient/lib/MozClient/VCS.pm
+++ b/src/mozclient/lib/MozClient/VCS.pm
@@ -59,6 +59,9 @@ sub new {
$self->{'want_branch'} = $$conf{'MOZCLIENT_BRANCH'}
if defined $$conf{'MOZCLIENT_BRANCH'} && !defined $self->{'want_branch'};
+ # The following options overwrite the conf files
+ $self->{'MOZCLIENT_EMBEDDED'} = 1 if $$opt{'embedded'};
+
bless($self, $class);
$self;
}
diff --git a/src/mozclient/mozclient.pl b/src/mozclient/mozclient.pl
index c6ee8b7..5c8d995 100755
--- a/src/mozclient/mozclient.pl
+++ b/src/mozclient/mozclient.pl
@@ -75,6 +75,7 @@ mozclient [-l] project-name
--tag|-t tag checkout using a tag
--tag|-t tag=ver checkout using a tag, hard-coding the version
--preserve-vcs|-p preserve VCS files
+ --embedded|-e create an embedded tarball
--debug|-D increase debug level
Examples:
@@ -181,6 +182,7 @@ GetOptions($opt,
'branch|b=s',
'date|d=s',
'tag|t=s',
+ 'embedded|e',
'preserve-vcs|p') || &help();
&help() unless $#ARGV >= 0;