summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog3
-rw-r--r--src/xpi.mk9
2 files changed, 12 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 7f9e58e..22f24d2 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -29,6 +29,9 @@ mozilla-devscripts (0.15) UNRELEASED; urgency=low
- wrote man page for med-xpi-{pack,unpack}
- add man/med-xpi-{pack,unpack}.1
- update src/Makefile
+ * xpi.mk:
+ - add MOZ_XPI_DOCUMENTED_LICENSE_FILES parameter to enable exclusion of
+ extra license files during installation of the XPI to the packaging tree
-- Benjamin Drung <bdrung@ubuntu.com> Wed, 12 Aug 2009 02:21:37 +0200
diff --git a/src/xpi.mk b/src/xpi.mk
index cfe2aaf..7ffd504 100644
--- a/src/xpi.mk
+++ b/src/xpi.mk
@@ -52,6 +52,11 @@
# usually xpi.mk creates the right links based on targetApplication
# parsed in install.rdf; if you need more directories, use this.
#
+# MOZ_XPI_DOCUMENTED_LICENSE_FILES (OPTIONAL):
+# defines extra license files which need to be excluded during
+# the installation of the XPI file to the packaging tree. When
+# using parameter, be sure that you documented _all_ excluded
+# license files in debian/copyright appropriately
#
# Deprecated variables:
#
@@ -180,7 +185,11 @@ endif
# ### general helper targets
stamp-unzip-%: $(XPI_FILE)
[ -d $(TEMPDIR) ] || mkdir -p $(TEMPDIR)
+ifneq (,$(MOZ_XPI_DOCUMENTED_LICENSE_FILES))
+ unzip -d $(TEMPDIR) $(XPI_DIR)$* -x $(MOZ_XPI_DOCUMENTED_LICENSE_FILES)
+else
unzip -d $(TEMPDIR) $(XPI_DIR)$*
+endif
touch $@
stamp-installlinks-%: