summaryrefslogtreecommitdiff
path: root/README
diff options
context:
space:
mode:
Diffstat (limited to 'README')
-rw-r--r--README15
1 files changed, 11 insertions, 4 deletions
diff --git a/README b/README
index 88d6374..36a303f 100644
--- a/README
+++ b/README
@@ -7,15 +7,22 @@ Those patches are targetting mozilla/client.mk and add targets to
fetch respectively nss, nspr and xulbrowser (browser build with libxul
from xulrunner package).
-Depends on cvs and quilt.
+Depends on cvs, wget and quilt.
To use:
- $ make (will fetch and patch mozilla/client.mk from cvs)
+ $ make (display usage)
+ Usage:
+ make client Fetch and patch mozilla client
+ make firefox-orig Create firefox-trunk sources tarball
+ make xulrunner-orig Create xulrunner-1.9 sources tarball
+ make nss-orig Create nss-trunk sources tarball
+ make nspr-orig Create nspr-trunk sources tarball
+
+ $ make client (fetch and patch mozilla/client.mk from cvs)
$ make -f mozilla/client.mk checkout MOZ_CO_PROJECT=nss
$ make -f mozilla/client.mk checkout MOZ_CO_PROJECT=nspr
$ make -f mozilla/client.mk checkout MOZ_CO_PROJECT=xulbrowser
- $ make xulbrowser-orig (will create a tarball suitable for firefox-trunk)
- (or make ff3-orig, which is an alias)
+