summaryrefslogtreecommitdiff
path: root/README
diff options
context:
space:
mode:
Diffstat (limited to 'README')
-rw-r--r--README18
1 files changed, 18 insertions, 0 deletions
diff --git a/README b/README
index ca802c5..96be739 100644
--- a/README
+++ b/README
@@ -49,6 +49,24 @@ To use :
- in debian/control: add mozilla-devscripts to Build-Depends
- in debian/rules: add "include /usr/share/mozilla-devscripts/yourproject.mk"
+Note: it is also possible to keep all project files outside of mozilla-devscripts.
+To do so, mozclient needs two variables:
+- MOZCLIENT_PROJECTNAME: the name of the conf file as described below, without the
+ ".conf" extension
+- MOZCLIENT_PROJECTDIR: a directory containing the project specific files to be used
+ by mozclient. It is not a recommended to use the debian directory directly because
+ there will be a confusion between debian/patches and $(MOZCLIENT_PROJECTDIR)/patches
+
+ex:
+ in debian/rules:
+ MOZCLIENT_PROJECTNAME = myproject
+ MOZCLIENT_PROJECTDIR = debian/mozclient
+ include /usr/share/mozilla-devscripts/mozclient.mk
+ in debian/mozclient:
+ - a mandatory file called myproject.conf
+ - an optional patches directory
+ - an optional myproject-remove.binonly.sh file
+
The following targets are then available to the caller of debian/rules:
- get-orig-source
Build a tarball according to parameters from project.mk