summaryrefslogtreecommitdiff
path: root/patches/nspr_target.patch
diff options
context:
space:
mode:
Diffstat (limited to 'patches/nspr_target.patch')
-rw-r--r--patches/nspr_target.patch84
1 files changed, 84 insertions, 0 deletions
diff --git a/patches/nspr_target.patch b/patches/nspr_target.patch
new file mode 100644
index 0000000..1da34c9
--- /dev/null
+++ b/patches/nspr_target.patch
@@ -0,0 +1,84 @@
+---
+ mozilla/client.mk | 8 +++++++-
+ 1 file changed, 7 insertions(+), 1 deletion(-)
+
+Index: mozclient/mozilla/client.mk
+===================================================================
+--- mozclient.orig/mozilla/client.mk 2007-09-02 21:09:06.000000000 +0200
++++ mozclient/mozilla/client.mk 2007-09-02 21:09:45.000000000 +0200
+@@ -54,16 +54,17 @@
+ # export CVSROOT=:pserver:anonymous:anonymous@cvs-mirror.mozilla.org:/cvsroot
+ # export CVSROOT=:pserver:username%somedomain.org@cvs.mozilla.org:/cvsroot
+ #
+ # You must specify which products/modules you wish to checkout, with
+ # MOZ_CO_PROJECT and MOZ_CO_MODULE variables.
+ #
+ # MOZ_CO_PROJECT possibilities include the following:
+ # nss
++# nspr
+ # suite (Seamonkey suite)
+ # browser (aka Firefox)
+ # mail (aka Thunderbird)
+ # minimo (small browser for devices)
+ # composer (standalone composer, aka NVU)
+ # calendar (aka Sunbird, use this to build the calendar extensions also)
+ # xulrunner
+ # camino
+@@ -102,16 +103,17 @@
+ # MOZ_POSTFLIGHT_ALL } variables contain space-separated lists
+ # MOZ_UNIFY_BDATE - Set to use the same bdate for each project in
+ # MOZ_BUILD_PROJECTS
+ #
+
+ AVAILABLE_PROJECTS = \
+ all \
+ nss \
++ nspr \
+ suite \
+ toolkit \
+ browser \
+ mail \
+ minimo \
+ composer \
+ calendar \
+ xulrunner \
+@@ -148,16 +150,20 @@
+
+ MODULES_nss := \
+ mozilla/dbm \
+ mozilla/security/nss \
+ mozilla/security/coreconf \
+ mozilla/security/dbm \
+ $(NULL)
+
++MODULES_nspr := \
++ mozilla/nsprpub \
++ $(NULL)
++
+ MODULES_core := \
+ $(MODULES_necko) \
+ mozilla/caps \
+ mozilla/content \
+ mozilla/db/mdb \
+ mozilla/db/mork \
+ mozilla/docshell \
+ mozilla/dom \
+@@ -608,17 +614,17 @@
+ CVSCO_NSS = $(CVS) $(CVS_FLAGS) co $(NSS_CO_FLAGS) $(CVS_CO_DATE_FLAGS) $(NSS_CO_MODULE)
+ else
+ CVSCO_NSS = $(CVS) $(CVS_FLAGS) co $(NSS_CO_FLAGS) $(NSS_CO_MODULE)
+ endif
+
+ ####################################
+ # CVS defines for NSPR
+ #
+-NSPR_CO_MODULE = mozilla/nsprpub
++NSPR_CO_MODULE = $(MODULES_nspr)
+ NSPR_CO_FLAGS := -P
+ ifdef MOZ_CO_FLAGS
+ NSPR_CO_FLAGS := $(MOZ_CO_FLAGS)
+ endif
+ NSPR_CO_FLAGS := $(NSPR_CO_FLAGS) $(if $(NSPR_CO_TAG),-r $(NSPR_CO_TAG),-A)
+
+ # Can only pull the tip or branch tags by date
+ ifeq (,$(filter-out HEAD %BRANCH,$(NSPR_CO_TAG)))