summaryrefslogtreecommitdiff
path: root/src/xpi-data-Debian.mk
diff options
context:
space:
mode:
Diffstat (limited to 'src/xpi-data-Debian.mk')
-rw-r--r--src/xpi-data-Debian.mk40
1 files changed, 40 insertions, 0 deletions
diff --git a/src/xpi-data-Debian.mk b/src/xpi-data-Debian.mk
new file mode 100644
index 0000000..2370414
--- /dev/null
+++ b/src/xpi-data-Debian.mk
@@ -0,0 +1,40 @@
+# -*- mode: makefile; coding: utf-8 -*-
+
+# Copyright (c) 2009 Canonical Ltd.
+# Author(s): Benjamin Drung <bdrung@ubuntu.com>
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+_xpi_makefile_path ?= /usr/share/mozilla-devscripts
+
+ifndef _xpi_data_Debian
+_xpi_data_Debian = 1
+
+include $(_xpi_makefile_path)/xpi-data-common.mk
+
+iceweasel_sol := 2.0
+iceweasel_eol := *
+
+icedove_sol := 1.5.0.7
+icedove_eol := *
+
+iceape_sol := 1.0.6
+iceape_eol := *
+
+packages_{ec8030f7-c20a-464f-9b0e-13a3a9e97384} += iceweasel
+packages_{3550f703-e582-4d05-9a08-453d09bdfdc6} += icedove
+packages_{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a} += iceape
+
+endif