summaryrefslogtreecommitdiff
path: root/src/xpi.mk
diff options
context:
space:
mode:
Diffstat (limited to 'src/xpi.mk')
-rw-r--r--src/xpi.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/xpi.mk b/src/xpi.mk
index 9385a03..a1f4925 100644
--- a/src/xpi.mk
+++ b/src/xpi.mk
@@ -194,7 +194,7 @@ ifneq (,$(MOZ_XPI_EMID))
XPI_EMID = $(MOZ_XPI_EMID)
else
XPI_EMID = $(sort $(shell xpath -q -e '/node()/Description/em:id/text() | //RDF:Description[@RDF:about="urn:mozilla:install-manifest"]/em:id/text()' $(1)/install.rdf 2>/dev/null) \
- $(shell xpath -q -e '//RDF:Description[@RDF:about="urn:mozilla:install-manifest"]/@em:id' $(1)/install.rdf 2>/dev/null | sed -e 's/.*"\(.*\)"/\1/'))
+ $(shell xpath -q -e '/node()/Description/@em:id | //RDF:Description[@RDF:about="urn:mozilla:install-manifest"]/@em:id' $(1)/install.rdf 2>/dev/null | sed -e 's/.*"\(.*\)"/\1/'))
endif
ifeq (,$(MOZ_XPI_DISABLE_AUTOLINKS))
@@ -249,7 +249,7 @@ autolinks-stamp: $(patsubst %,unzip-%-stamp,$(XPI_BASE_FILE)) $(foreach mozilla,
$(if $(XPI_FILE),,@echo "xpi.mk: No xpi file found. Did you create one?"; \
echo "xpi.mk: Please check MOZ_XPI_BUILD_COMMAND and maybe MOZ_XPI_FILE!"; \
exit 2)
- $(if $(XPI_EMID),,@echo "xpi.mk: Detecting the extension manager ID failed."; \
+ $(if $(call XPI_EMID,$(TEMPDIR)),,@echo "xpi.mk: Detecting the extension manager ID failed."; \
echo "xpi.mk: This is either a bug in the install.rdf file or in mozilla-devscripts."; \
echo "xpi.mk: Patch the install.rdf file or use MOZ_XPI_EMID as workaround."; \
exit 3)