summaryrefslogtreecommitdiff
path: root/src/xpi.mk
diff options
context:
space:
mode:
Diffstat (limited to 'src/xpi.mk')
-rw-r--r--src/xpi.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/xpi.mk b/src/xpi.mk
index cfe2aaf..a5882b4 100644
--- a/src/xpi.mk
+++ b/src/xpi.mk
@@ -52,6 +52,9 @@
# usually xpi.mk creates the right links based on targetApplication
# parsed in install.rdf; if you need more directories, use this.
#
+# MOZ_XPI_EXCLUDE_FILES (OPTIONAL):
+# defines extra directories and files which should be excluded
+# during preparation of the XPI file.
#
# Deprecated variables:
#
@@ -180,7 +183,11 @@ endif
# ### general helper targets
stamp-unzip-%: $(XPI_FILE)
[ -d $(TEMPDIR) ] || mkdir -p $(TEMPDIR)
+ifneq (,$(MOZ_XPI_EXCLUDE_FILES))
+ unzip -d $(TEMPDIR) $(XPI_DIR)$* -x $(MOZ_XPI_EXCLUDE_FILES)
+else
unzip -d $(TEMPDIR) $(XPI_DIR)$*
+endif
touch $@
stamp-installlinks-%: