summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorRuben Undheim <ruben.undheim@gmail.com>2018-11-03 13:54:43 +0100
committerRuben Undheim <ruben.undheim@gmail.com>2018-11-03 14:02:16 +0100
commitdd3ad36bc40d8e29c6df935a4b5eed72099e4ad9 (patch)
treeba2b55edb09ce83fcca79690d084620e1cf7260a /debian/rules
parentce934a80f0024fb15f006ebdb5c26d0dcf4073d2 (diff)
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules10
1 files changed, 0 insertions, 10 deletions
diff --git a/debian/rules b/debian/rules
index a3681ec..b3f2e78 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,15 +6,5 @@ export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
-PKD = $(abspath $(dir $(MAKEFILE_LIST)))
-PKG = $(word 2,$(shell dpkg-parsechangelog -l$(PKD)/changelog | grep ^Source))
-VER ?= $(shell dpkg-parsechangelog -l$(PKD)/changelog | perl -ne 'print $$1 if m{^Version:\s+(?:\d+:)?(\d.*)(?:\-\d+.*)};')
-
-
%:
dh $@
-
-get-orig-source: $(info I: $(PKG)_$(VER))
- @echo "# Downloading..."
- uscan --noconf --verbose --rename --destdir=$(CURDIR) --force-download --download-version $(VER) $(PKD)
-