summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorRuben Undheim <ruben.undheim@gmail.com>2018-08-06 22:09:58 +0200
committerRuben Undheim <ruben.undheim@gmail.com>2018-08-06 22:09:58 +0200
commitaba34cc83ccb075879add8824527c894f5ba5fa7 (patch)
tree37290ffd194a296beb34f4e10cc69862af24fa58 /src/CMakeLists.txt
Import effective orig tree for upstream version 0.1.6
This includes the contents of the .orig(s), minus any debian/ directory. [git-debrebase import-from-dgit-view upstream-import-convert: 0.1.6]
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..d88d3e7
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,22 @@
+add_library(mrtd SHARED bac.c bachelper.c fileread.c hardware.c crypto-gcrypt.c)
+target_link_libraries(mrtd nfc)
+target_link_libraries(mrtd usb)
+target_link_libraries(mrtd gcrypt)
+
+add_executable(mrtdreader mrtdreader.c)
+target_link_libraries(mrtdreader mrtd)
+
+set_target_properties(mrtd PROPERTIES VERSION 0.0.1 SOVERSION 0)
+
+install(TARGETS mrtdreader DESTINATION bin)
+if(${CMAKE_INSTALL_PREFIX} STREQUAL "/usr")
+ install(TARGETS mrtd DESTINATION lib/${CMAKE_LIBRARY_ARCHITECTURE})
+else()
+ install(TARGETS mrtd DESTINATION lib)
+endif()
+
+install(FILES mrtd.h DESTINATION include/mrtd)
+install(FILES bac.h DESTINATION include/mrtd)
+install(FILES bachelper.h DESTINATION include/mrtd)
+install(FILES crypto.h DESTINATION include/mrtd)
+install(FILES fileread.h DESTINATION include/mrtd)