summaryrefslogtreecommitdiff
path: root/makedist
diff options
context:
space:
mode:
authorBdale Garbee <bdale@gag.com>2009-02-15 18:17:54 +0100
committerBdale Garbee <bdale@gag.com>2009-02-15 18:17:54 +0100
commit1c3607e4d1f94869e7887568fb40d16bb0d2407d (patch)
treef7a37bbbea5791814281affed9da11b47fbd080b /makedist
Import mtx_1.3.12.orig.tar.gz
[dgit import orig mtx_1.3.12.orig.tar.gz]
Diffstat (limited to 'makedist')
-rwxr-xr-xmakedist19
1 files changed, 19 insertions, 0 deletions
diff --git a/makedist b/makedist
new file mode 100755
index 0000000..93f8121
--- /dev/null
+++ b/makedist
@@ -0,0 +1,19 @@
+#!/bin/sh
+
+# note -- this assumes 'bash' shell, GNU tar, 'gzip'.
+
+# pass a version number e.g. 1.4.3 as 1st parameter...
+ME=`pwd`
+
+# okay, now to create a spec file w/the proper version number:
+sed -e "1,\$s/@@VERSION@@/${1}/g" <mtx.spec.in >mtx.spec
+
+cd ..
+if [ ! -s mtx-${1} ]
+then
+ ln -s "${ME}" "mtx-${1}"
+fi
+
+
+tar --exclude CVS --exclude .svn -czvhf mtx-${1}.tar.gz mtx-${1}
+