summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/bash_completion45
-rw-r--r--debian/changelog159
-rw-r--r--debian/compat1
-rw-r--r--debian/control16
-rw-r--r--debian/copyright15
-rw-r--r--debian/dirs2
-rwxr-xr-xdebian/rules69
7 files changed, 307 insertions, 0 deletions
diff --git a/debian/bash_completion b/debian/bash_completion
new file mode 100644
index 0000000..71852c0
--- /dev/null
+++ b/debian/bash_completion
@@ -0,0 +1,45 @@
+# mtx completion by Jon Middleton <jjm@ixtab.org.uk>
+#
+# $Id: bash_completion,v 1.1 2004-02-15 05:43:25 bdale Exp $
+
+_mtx()
+{
+ local cur prev options tapes drives
+
+ COMPREPLY=()
+ cur=${COMP_WORDS[COMP_CWORD]}
+ prev=${COMP_WORDS[COMP_CWORD-1]}
+
+ options="-f nobarcode invert noattach --version inquiry noattach \
+ inventory status load unload eepos first last next"
+
+ tapes=$(mtx status | \
+ awk '/Storage Element [0-9]+:Full/ { printf "%s ", $3 }')
+ tapes=${tapes//:Full}
+
+ drives=$(mtx status | \
+ awk '/Data Transfer Element [0-9]+:(Full|Empty)/ { printf "%s ", $4 }')
+ drives=${drives//:Full}
+ drives=${drives//:Empty}
+
+ if [ $COMP_CWORD -gt 1 ]; then
+ case $prev in
+ load)
+ COMPREPLY=( $( compgen -W "$tapes" -- $cur ) )
+ ;;
+ unload|first|last|next)
+ COMPREPLY=( $( compgen -W "$drives" -- $cur ) )
+ ;;
+ -f)
+ true
+ ;;
+ *)
+ true
+ ;;
+ esac
+ else
+ COMPREPLY=( $( compgen -W "$options" -- $cur ) )
+ fi
+ return 0
+}
+complete -F _mtx mtx
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..860dd53
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,159 @@
+mtx (1.3.12-1) unstable; urgency=low
+
+ * Incorporate debian packaging into upsteam version
+ * Remove strip of binaries
+ * Remove unsupported nsmhack from list of binaries built by default
+ * Add support for building outside of source tree
+ * Update copyrights
+ * Fix typo in mtx.1 man page
+ * Clear outstanding UNIT ATTENTION state at start
+
+ -- Robert Nelson <robertn@the-nelsons.org> Tue, 19 Aug 2008 09:04:00 +0000
+
+mtx (1.3.11-1) unstable; urgency=low
+
+ * new upstream version, closes: #425687, #425688
+ * don't let Makefile.in strip binaries, let dh_strip do it, closes: #437589
+
+ -- Bdale Garbee <bdale@gag.com> Tue, 15 Apr 2008 14:34:32 -0600
+
+mtx (1.2.17rel-2) unstable; urgency=low
+
+ * update config.sub and config.guess in rules clean target using the
+ autotools-dev package, closes: #367467
+
+ -- Bdale Garbee <bdale@gag.com> Sat, 19 Aug 2006 18:44:54 -0600
+
+mtx (1.2.17rel-1) unstable; urgency=low
+
+ * new upstream version
+
+ -- Bdale Garbee <bdale@gag.com> Wed, 28 Jun 2006 23:57:44 -0400
+
+mtx (1.2.16rel-5) unstable; urgency=low
+
+ * add build-deps needed for GNU/kFreeBSD, closes: #367467
+ * update debhelper build dependency
+
+ -- Bdale Garbee <bdale@gag.com> Wed, 28 Jun 2006 23:42:00 -0400
+
+mtx (1.2.16rel-4) unstable; urgency=medium
+
+ * revert SG_SCSI_DEFAULT_TIMEOUT to 5 minutes since at least the Sony
+ TLS-9000 takes more than a minute to load sometimes, closes: #229169
+ * remove 'previous' from command summary, since it's not actually
+ implemented in the program, closes: #230041
+ * include bash_completion file from Jon Middleton, closes: #227456
+
+ -- Bdale Garbee <bdale@gag.com> Sat, 14 Feb 2004 22:36:23 -0700
+
+mtx (1.2.16rel-3) unstable; urgency=low
+
+ * apply patch from Torsten Werner <twerner@debian.org> that elminates
+ hard-coding of the value of HZ, closes: #224147
+
+ -- Bdale Garbee <bdale@gag.com> Tue, 16 Dec 2003 10:04:26 -0700
+
+mtx (1.2.16rel-2) unstable; urgency=low
+
+ * apply patch from R.A.Owen <rao3@leicester.ac.uk> that fixes the "staggered"
+ output from the status command on some changers, closes: #129910
+
+ -- Bdale Garbee <bdale@gag.com> Tue, 9 Apr 2002 19:30:06 -0600
+
+mtx (1.2.16rel-1) unstable; urgency=low
+
+ * new upstream version, bug-fixing release, reportedly fixes timeout
+ problem with some drives, closes: #113947
+
+ -- Bdale Garbee <bdale@gag.com> Mon, 4 Mar 2002 01:27:48 -0700
+
+mtx (1.2.15-1) unstable; urgency=low
+
+ * new upstream source
+ * update standards version, rebuild rules file
+ * man pages all included now, mtx-changer and other pieces from contrib
+ provided as examples, though chg-mtx in the amanda package is probably
+ a better choice for use with amanda, closes: #113728
+ * apply diffs to correct "spelling errors" (actually hyphenation) in the
+ descriptions in the control file, closes: #125160
+
+ -- Bdale Garbee <bdale@gag.com> Sun, 30 Dec 2001 21:28:46 -0700
+
+mtx (1.2.10-1) unstable; urgency=low
+
+ * new upstream source
+
+ -- Bdale Garbee <bdale@gag.com> Mon, 11 Dec 2000 17:34:13 -0700
+
+mtx (1.0-10) frozen unstable; urgency=low
+
+ * deliver mtx.doc, lost when the package was made FHS compliant,
+ closes: #56276 Target frozen since including the documentation
+ is worthwhile for potato, and there is no added risk.
+
+ -- Bdale Garbee <bdale@gag.com> Wed, 9 Feb 2000 12:27:58 -0700
+
+mtx (1.0-9) unstable; urgency=low
+
+ * fix postinst/postrm scripts to be executable again
+
+ -- Bdale Garbee <bdale@gag.com> Tue, 11 Jan 2000 23:00:17 -0700
+
+mtx (1.0-8) unstable; urgency=low
+
+ * update to latest standards revision, add Build-Depends
+ * fix all the lintian errors that aren't intentional, override the two
+ permissions warnings since they're precisely what is needed
+
+ -- Bdale Garbee <bdale@gag.com> Fri, 7 Jan 2000 02:47:08 -0700
+
+mtx (1.0-7) unstable; urgency=low
+
+ * grab a local copy of scsi_ioctl.h from the 2.2.10 kernel source tree. This
+ doesn't change often in any way we care about, and this is much simpler
+ than having to reference a live kernel tree somewhere...
+ * move to debhelper and CVS
+
+ -- Bdale Garbee <bdale@gag.com> Sun, 20 Jun 1999 10:42:39 -0600
+
+mtx (1.0-6) unstable; urgency=low
+
+ * put mtx in group backup, setuid root, perms set so that only members of
+ group backup can run mtx. This makes mtx compatible with amanda.
+
+ -- Bdale Garbee <bdale@gag.com> Tue, 27 Jan 1998 15:06:13 -0700
+
+mtx (1.0-5) unstable; urgency=low
+
+ * explicit include path to find <scsi/scsi_ioctl.h> in the
+ /usr/src/linux/include tree. closes bug 16877
+
+ -- Bdale Garbee <bdale@gag.com> Sun, 25 Jan 1998 23:02:46 -0700
+
+mtx (1.0-4) unstable; urgency=low
+
+ * actually install the mtx.doc file that's referenced in the man page /o\
+
+ -- Bdale Garbee <bdale@gag.com> Sun, 21 Sep 1997 02:38:50 -0600
+
+mtx (1.0-3) unstable; urgency=low
+
+ * libc6
+
+ -- Bdale Garbee <bdale@gag.com> Thu, 4 Sep 1997 02:56:39 -0600
+
+mtx (1.0-2) unstable; urgency=low
+
+ * Add an 'mtx-changer' wrapper script from the amanda-users mailing list
+ to make this more useful with Amanda.
+ * Hack mtx-changer to report 6 slots instead of 4, since I have an HP
+ SureStore 12000e. Should make it configurable, someday.
+
+ -- Bdale Garbee <bdale@gag.com> Sun, 10 Aug 1997 03:50:42 -0600
+
+mtx (1.0-1) unstable; urgency=low
+
+ * Initial Release.
+
+ -- Bdale Garbee <bdale@gag.com> Sun, 10 Aug 1997 03:05:18 -0600
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..b8626c4
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+4
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..fa6c9d0
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,16 @@
+Source: mtx
+Section: admin
+Priority: extra
+Maintainer: Robert Nelson <robertn@the-nelsons.org>
+Build-Depends: debhelper (>= 4), libcam-dev [kfreebsd-i386 kfreebsd-amd64], autotools-dev
+Standards-Version: 3.7.3
+
+Package: mtx
+Architecture: any
+Depends: ${shlibs:Depends}
+Description: controls tape autochangers
+ MTX can be used to manipulate tape auto-changers, also known as "jukeboxes",
+ such that backup software can make use of the multiple tape capabilities of
+ the auto-changer. In particular, this is necessary glue for using a backup
+ system like Amanda with a DDS auto-changer like the HP Surestore 12000e.
+
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..28fd2e0
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,15 @@
+This package was debianized by Bdale Garbee bdale@gag.com on
+Sun, 10 Aug 1997 03:05:18 -0600.
+
+mtx was downloaded from http://mtx.sourceforge.net/
+
+Copyright:
+
+ Copyright 1997, 1998 Leonard Zubkoff <lnz@dandelion.com>
+ Changes copyright 2000, 2001 Eric Green <eric@badtux.org>
+ Changes copyright 2007-2008 by Robert Nelson <robertn@the-nelsons.org>
+
+ GPL, version 2
+
+On Debian GNU/Linux systems, the complete text of the GNU General
+Public License can be found in `/usr/share/common-licenses/GPL'.
diff --git a/debian/dirs b/debian/dirs
new file mode 100644
index 0000000..ce5d4fb
--- /dev/null
+++ b/debian/dirs
@@ -0,0 +1,2 @@
+etc/bash_completion.d
+usr/sbin
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..79c0cb2
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,69 @@
+#!/usr/bin/make -f
+# Sample debian/rules that uses debhelper.
+# GNU copyright 1997 to 1999 by Joey Hess.
+
+export DH_VERBOSE=1
+
+configure: configure-stamp
+configure-stamp:
+ dh_testdir
+ ./configure --prefix=/usr
+ touch configure-stamp
+
+build: build-stamp
+
+build-stamp: configure-stamp
+ dh_testdir
+ $(MAKE)
+ touch build-stamp
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
+ [ ! -f Makefile ] || $(MAKE) distclean
+
+ -test -r /usr/share/misc/config.sub && \
+ cp -f /usr/share/misc/config.sub config.sub
+ -test -r /usr/share/misc/config.guess && \
+ cp -f /usr/share/misc/config.guess config.guess
+
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ make install bindir=`pwd`/debian/mtx/bin prefix=`pwd`/debian/mtx/usr \
+ mandir=`pwd`/debian/mtx/usr/share/man
+ install -o root -g root -m 0644 debian/bash_completion \
+ debian/mtx/etc/bash_completion.d/mtx
+
+# Build architecture-independent files here.
+binary-indep: build install
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installdocs
+ dh_installexamples contrib/*
+ dh_installmenu
+ dh_installcron
+# dh_installman
+ dh_installinfo
+ dh_installchangelogs CHANGES
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure